CVE-2003-0672
Format string vulnerability in pam-pgsql 0.5.2 and earlier allows remote attackers to execute...
Format string vulnerability in pam-pgsql 0.5.2 and earlier allows remote attackers to execute arbitrary code via the username that isp rovided during authentication, which is not properly handled when recording a log message.
Exploit likelihood
What each source reports
NVD Score used
7.5
Format string vulnerability in pam-pgsql 0.5.2 and earlier allows remote attackers to execute arbitrary code via the username that isp rovided during authentication, which is not properly handled when recording a log message.
- Record
CVE-2003-0672- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Format string vulnerability in pam-pgsql 0.5.2 and earlier allows remote attackers to execute arbitrary code via the username that isp rovided during authentication, which is not properly handled when recording a log message.
- Record
CVE-2003-0672- Updated
- 2026-11-02
EUVDEUVD-2003-0666 No score
Format string vulnerability in pam-pgsql 0.5.2 and earlier allows remote attackers to execute arbitrary code via the username that isp rovided during authentication, which is not properly handled when recording a log message.
- Record
EUVD-2003-0666- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xwrx-9qxp-9w34 No score
Format string vulnerability in pam-pgsql 0.5.2 and earlier allows remote attackers to execute...
Format string vulnerability in pam-pgsql 0.5.2 and earlier allows remote attackers to execute arbitrary code via the username that isp rovided during authentication, which is not properly handled when recording a log message.
- Record
GHSA-xwrx-9qxp-9w34- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pam-pgsqlDebian:3.0 |
before 0.5.2-3woody1 | 0.5.2-3woody1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2003-0672 is a high vulnerability (CVSS 7.5) in Leon J Breedt Pam-pgsql, published August 8, 2003. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.06%, the 87th percentile. Fixed in pam-pgsql 0.5.2-3woody1.