CVE-2003-0685
Buffer overflow in Netris 0.52 and earlier, and possibly other versions, allows remote malicious...
CVE-2003-0685 is a high vulnerability (CVSS 7.5) in Netris, published August 15, 2003. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.42%, the 84th percentile. Fixed in netris 0.52-1.
Buffer overflow in Netris 0.52 and earlier, and possibly other versions, allows remote malicious Netris servers to execute arbitrary code on netris clients via a long server response.
Exploit likelihood
What each source reports
NVD Score used
7.5
Buffer overflow in Netris 0.52 and earlier, and possibly other versions, allows remote malicious Netris servers to execute arbitrary code on netris clients via a long server response.
- Record
CVE-2003-0685- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Buffer overflow in Netris 0.52 and earlier, and possibly other versions, allows remote malicious Netris servers to execute arbitrary code on netris clients via a long server response.
- Record
CVE-2003-0685- Updated
- 2026-11-02
EUVDEUVD-2003-0676 No score
Buffer overflow in Netris 0.52 and earlier, and possibly other versions, allows remote malicious Netris servers to execute arbitrary code on netris clients via a long server response.
- Record
EUVD-2003-0676- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wwgx-gv4h-mmw4 No score
Buffer overflow in Netris 0.52 and earlier, and possibly other versions, allows remote malicious...
Buffer overflow in Netris 0.52 and earlier, and possibly other versions, allows remote malicious Netris servers to execute arbitrary code on netris clients via a long server response.
- Record
GHSA-wwgx-gv4h-mmw4- Updated
- 2026-11-02
OSV No score
Buffer overflow in Netris 0.52 and earlier, and possibly other versions, allows remote malicious Netris servers to execute arbitrary code on netris clients via a long server response.
- Record
CVE-2003-0685- Updated
- 2026-11-02
OSVDEBIAN-CVE-2003-0685 No score
Buffer overflow in Netris 0.52 and earlier, and possibly other versions, allows remote malicious Netris servers to execute arbitrary code on netris clients via a long server response.
- Record
DEBIAN-CVE-2003-0685- Updated
- 2026-11-02
Affected products
Affected packages
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |