Every CVE Search/ Get API key

CVE-2004-0041

The mod_auth_shadow module 1.4 and earlier does not properly enforce the expiration of a user...

7.5 HighFix available

The mod_auth_shadow module 1.4 and earlier does not properly enforce the expiration of a user account and password, which could allow remote authenticated users to bypass intended access restrictions.

Exploit likelihood

1.58%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The mod_auth_shadow module 1.4 and earlier does not properly enforce the expiration of a user account and password, which could allow remote authenticated users to bypass intended access restrictions.

Record
CVE-2004-0041
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The mod_auth_shadow module 1.4 and earlier does not properly enforce the expiration of a user account and password, which could allow remote authenticated users to bypass intended access restrictions.

Record
CVE-2004-0041
Updated
2026-11-02
EUVDEUVD-2004-0041 No score

The mod_auth_shadow module 1.4 and earlier does not properly enforce the expiration of a user account and password, which could allow remote authenticated users to bypass intended access restrictions.

Record
EUVD-2004-0041
Updated
2026-11-03
GitHub AdvisoriesGHSA-6f2v-whrw-9jm4 No score

The mod_auth_shadow module 1.4 and earlier does not properly enforce the expiration of a user...

The mod_auth_shadow module 1.4 and earlier does not properly enforce the expiration of a user account and password, which could allow remote authenticated users to bypass intended access restrictions.

Record
GHSA-6f2v-whrw-9jm4
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mod-auth-shadow
Debian:3.0
before 1.3-3.1woody.1
1.3-3.1woody.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0041 is a high vulnerability (CVSS 7.5) in Mod Auth Shadow Auth Shadow, published January 12, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.58%, the 75th percentile. Fixed in mod-auth-shadow 1.3-3.1woody.1.

References

MoveEnter Open