Every CVE Search/ Get API key

CVE-2004-0176

Multiple buffer overflows in Ethereal 0.8.13 to 0.10.2 allow remote attackers to cause a denial...

5.0 MediumPublic exploitFix available

Multiple buffer overflows in Ethereal 0.8.13 to 0.10.2 allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) NetFlow, (2) IGAP, (3) EIGRP, (4) PGM, (5) IrDA, (6) BGP, (7) ISUP, or (8) TCAP dissectors.

Exploit likelihood

67.1%Up 17.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Multiple buffer overflows in Ethereal 0.8.13 to 0.10.2 allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) NetFlow, (2) IGAP, (3) EIGRP, (4) PGM, (5) IrDA, (6) BGP, (7) ISUP, or (8) TCAP dissectors.

Record
CVE-2004-0176
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

Multiple buffer overflows in Ethereal 0.8.13 to 0.10.2 allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) NetFlow, (2) IGAP, (3) EIGRP, (4) PGM, (5) IrDA, (6) BGP, (7) ISUP, or (8) TCAP dissectors.

Record
CVE-2004-0176
Updated
2026-11-02
EUVDEUVD-2004-0176 No score

Multiple buffer overflows in Ethereal 0.8.13 to 0.10.2 allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) NetFlow, (2) IGAP, (3) EIGRP, (4) PGM, (5) IrDA, (6) BGP, (7) ISUP, or (8) TCAP dissectors.

Record
EUVD-2004-0176
Updated
2026-11-03
GitHub AdvisoriesGHSA-rfxc-wgf7-qphr No score

Multiple buffer overflows in Ethereal 0.8.13 to 0.10.2 allow remote attackers to cause a denial...

Multiple buffer overflows in Ethereal 0.8.13 to 0.10.2 allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) NetFlow, (2) IGAP, (3) EIGRP, (4) PGM, (5) IrDA, (6) BGP, (7) ISUP, or (8) TCAP dissectors.

Record
GHSA-rfxc-wgf7-qphr
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ethereal
Debian:3.0
before 0.9.4-1woody7
0.9.4-1woody7
ethereal
Red Hat:enterprise_linux:3::as
From an advisory covering 4 CVEs
before 0:0.10.3-0.30E.1
0:0.10.3-0.30E.1
ethereal-gnome
Red Hat:enterprise_linux:3::as
From an advisory covering 4 CVEs
before 0:0.10.3-0.30E.1
0:0.10.3-0.30E.1
ethereal
Red Hat:enterprise_linux:3::desktop
From an advisory covering 4 CVEs
before 0:0.10.3-0.30E.1
0:0.10.3-0.30E.1
ethereal-gnome
Red Hat:enterprise_linux:3::desktop
From an advisory covering 4 CVEs
before 0:0.10.3-0.30E.1
0:0.10.3-0.30E.1
ethereal
Red Hat:enterprise_linux:3::es
From an advisory covering 4 CVEs
before 0:0.10.3-0.30E.1
0:0.10.3-0.30E.1
ethereal-gnome
Red Hat:enterprise_linux:3::es
From an advisory covering 4 CVEs
before 0:0.10.3-0.30E.1
0:0.10.3-0.30E.1
ethereal
Red Hat:enterprise_linux:3::ws
From an advisory covering 4 CVEs
before 0:0.10.3-0.30E.1
0:0.10.3-0.30E.1
ethereal-gnome
Red Hat:enterprise_linux:3::ws
From an advisory covering 4 CVEs
before 0:0.10.3-0.30E.1
0:0.10.3-0.30E.1

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
affected, exploits, facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0176 is a medium vulnerability (CVSS 5.0) in Ethereal Group Ethereal, published March 25, 2004. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 67.1%, the 99th percentile. Fixed in ethereal 0.9.4-1woody7.

References

Show 41 moreShow less
MoveEnter Open