CVE-2004-0227
Buffer overflow in the zms script in ZoneMinder before 1.19.2 may allow a remote attacker to...
Buffer overflow in the zms script in ZoneMinder before 1.19.2 may allow a remote attacker to execute arbitrary code via a long query string.
Exploit likelihood
What each source reports
NVD Score used
7.5
Buffer overflow in the zms script in ZoneMinder before 1.19.2 may allow a remote attacker to execute arbitrary code via a long query string.
- Record
CVE-2004-0227- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Buffer overflow in the zms script in ZoneMinder before 1.19.2 may allow a remote attacker to execute arbitrary code via a long query string.
- Record
CVE-2004-0227- Updated
- 2026-11-02
EUVDEUVD-2004-0227 No score
Buffer overflow in the zms script in ZoneMinder before 1.19.2 may allow a remote attacker to execute arbitrary code via a long query string.
- Record
EUVD-2004-0227- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vw27-grvr-mcmx No score
Buffer overflow in the zms script in ZoneMinder before 1.19.2 may allow a remote attacker to...
Buffer overflow in the zms script in ZoneMinder before 1.19.2 may allow a remote attacker to execute arbitrary code via a long query string.
- Record
GHSA-vw27-grvr-mcmx- Updated
- 2026-11-02
OSV No score
Buffer overflow in the zms script in ZoneMinder before 1.19.2 may allow a remote attacker to execute arbitrary code via a long query string.
- Record
CVE-2004-0227- Updated
- 2026-11-02
OSVDEBIAN-CVE-2004-0227 No score
Buffer overflow in the zms script in ZoneMinder before 1.19.2 may allow a remote attacker to execute arbitrary code via a long query string.
- Record
DEBIAN-CVE-2004-0227- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
zoneminderDebian:12 |
before 1.22.3-1 | 1.22.3-1 |
zoneminderDebian:13 |
before 1.22.3-1 | 1.22.3-1 |
zoneminderDebian:14 |
before 1.22.3-1 | 1.22.3-1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2004-0227 is a high vulnerability (CVSS 7.5) in Triornis Zoneminder, published May 12, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.22%, the 88th percentile. Fixed in zoneminder 1.22.3-1.