Every CVE Search/ Get API key

CVE-2004-0235

Multiple directory traversal vulnerabilities in LHA 1.14 allow remote attackers or local users to...

6.4 MediumFix available

Multiple directory traversal vulnerabilities in LHA 1.14 allow remote attackers or local users to create arbitrary files via an LHA archive containing filenames with (1) .. sequences or (2) absolute pathnames with double leading slashes ("//absolute/path").

Exploit likelihood

4.12%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.4

Multiple directory traversal vulnerabilities in LHA 1.14 allow remote attackers or local users to create arbitrary files via an LHA archive containing filenames with (1) .. sequences or (2) absolute pathnames with double leading slashes ("//absolute/path").

Record
CVE-2004-0235
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:P/I:P/A:N
Updated
2026-11-02
CVE List No score

Multiple directory traversal vulnerabilities in LHA 1.14 allow remote attackers or local users to create arbitrary files via an LHA archive containing filenames with (1) .. sequences or (2) absolute pathnames with double leading slashes ("//absolute/path").

Record
CVE-2004-0235
Updated
2026-11-02
EUVDEUVD-2004-0235 No score

Multiple directory traversal vulnerabilities in LHA 1.14 allow remote attackers or local users to create arbitrary files via an LHA archive containing filenames with (1) .. sequences or (2) absolute pathnames with double leading slashes ("//absolute/path").

Record
EUVD-2004-0235
Updated
2026-11-03
GitHub AdvisoriesGHSA-v492-qprp-rvhr No score

Multiple directory traversal vulnerabilities in LHA 1.14 allow remote attackers or local users to...

Multiple directory traversal vulnerabilities in LHA 1.14 allow remote attackers or local users to create arbitrary files via an LHA archive containing filenames with (1) .. sequences or (2) absolute pathnames with double leading slashes ("//absolute/path").

Record
GHSA-v492-qprp-rvhr
Updated
2026-11-02

Affected products

Show 1 moreShow less

Affected packages

Affected packages
PackageAffectedFixed
lha
Debian:3.0
before 1.14i-2woody1, plus listed versions
1.00-31.00-51.00-61.14c-11.14e-01.14i-2
1.14i-2woody1
lha
Red Hat:enterprise_linux:3::as
before 0:1.14i-10.2
0:1.14i-10.2
lha-debuginfo
Red Hat:enterprise_linux:3::as
before 0:1.14i-10.2
0:1.14i-10.2
lha
Red Hat:enterprise_linux:3::desktop
before 0:1.14i-10.2
0:1.14i-10.2
lha-debuginfo
Red Hat:enterprise_linux:3::desktop
before 0:1.14i-10.2
0:1.14i-10.2
lha
Red Hat:enterprise_linux:3::es
before 0:1.14i-10.2
0:1.14i-10.2
lha-debuginfo
Red Hat:enterprise_linux:3::es
before 0:1.14i-10.2
0:1.14i-10.2
lha
Red Hat:enterprise_linux:3::ws
before 0:1.14i-10.2
0:1.14i-10.2
lha-debuginfo
Red Hat:enterprise_linux:3::ws
before 0:1.14i-10.2
0:1.14i-10.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0235 is a medium vulnerability (CVSS 6.4) in Redhat Lha, published May 5, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.12%, the 90th percentile. Fixed in lha 1.14i-2woody1.

References

Show 20 moreShow less
MoveEnter Open