CVE-2004-0374
Interchange before 5.0.1 allows remote attackers to "expose the content of arbitrary variables"...
Interchange before 5.0.1 allows remote attackers to "expose the content of arbitrary variables" and read or modify sensitive SQL information via an HTTP request ending with the "SQLUSER" string.
Exploit likelihood
What each source reports
NVD Score used
6.4
Interchange before 5.0.1 allows remote attackers to "expose the content of arbitrary variables" and read or modify sensitive SQL information via an HTTP request ending with the "SQLUSER" string.
- Record
CVE-2004-0374- CVSS 2.0
- 6.4 Medium
AV:N/AC:L/Au:N/C:P/I:P/A:N - Updated
- 2026-11-02
CVE List No score
Interchange before 5.0.1 allows remote attackers to "expose the content of arbitrary variables" and read or modify sensitive SQL information via an HTTP request ending with the "SQLUSER" string.
- Record
CVE-2004-0374- Updated
- 2026-11-02
EUVDEUVD-2004-0374 No score
Interchange before 5.0.1 allows remote attackers to "expose the content of arbitrary variables" and read or modify sensitive SQL information via an HTTP request ending with the "SQLUSER" string.
- Record
EUVD-2004-0374- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-v6q8-f3pg-p46q No score
Interchange before 5.0.1 allows remote attackers to "expose the content of arbitrary variables"...
Interchange before 5.0.1 allows remote attackers to "expose the content of arbitrary variables" and read or modify sensitive SQL information via an HTTP request ending with the "SQLUSER" string.
- Record
GHSA-v6q8-f3pg-p46q- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
interchangeDebian:3.0 |
before 4.8.3.20020306-1.woody.2 | 4.8.3.20020306-1.woody.2 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Interchange 4.8.x/5.0 - Remote Information Disclosure | 2004-03-30 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2004-0374 is a medium vulnerability (CVSS 6.4) in Interchange Development Group Interchange, published April 2, 2004. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 2.83%, the 86th percentile. Fixed in interchange 4.8.3.20020306-1.woody.2.
References
icdevgroup.org/pipermail/interchange-announce/2004/000043.html
securityfocus.com/bid/10005
ftp.icdevgroup.org/interchange/5.0/WHATSNEW
exchange.xforce.ibmcloud.com/vulnerabilities/15670
secunia.com/advisories/11234
debian.org/security/2004/dsa-471
nvd.nist.gov/vuln/detail/CVE-2004-0374
github.com/advisories/GHSA-v6q8-f3pg-p46q