Every CVE Search/ Get API key

CVE-2004-0394

A "potential" buffer overflow exists in the panic() function in Linux 2.4.x, although it may not...

2.1 LowFix available

A "potential" buffer overflow exists in the panic() function in Linux 2.4.x, although it may not be exploitable due to the functionality of panic.

Exploit likelihood

0.49%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.1

A "potential" buffer overflow exists in the panic() function in Linux 2.4.x, although it may not be exploitable due to the functionality of panic.

Record
CVE-2004-0394
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:P/I:N/A:N
Updated
2026-11-02
CVE List No score

A "potential" buffer overflow exists in the panic() function in Linux 2.4.x, although it may not be exploitable due to the functionality of panic.

Record
CVE-2004-0394
Updated
2026-11-02
EUVDEUVD-2004-0394 No score

A "potential" buffer overflow exists in the panic() function in Linux 2.4.x, although it may not be exploitable due to the functionality of panic.

Record
EUVD-2004-0394
Updated
2026-11-03
GitHub AdvisoriesGHSA-73x7-w549-42qm No score

A "potential" buffer overflow exists in the panic() function in Linux 2.4.x, although it may not...

A "potential" buffer overflow exists in the panic() function in Linux 2.4.x, although it may not be exploitable due to the functionality of panic.

Record
GHSA-73x7-w549-42qm
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
kernel-source-2.4.16
Debian:3.0
before 2.4.16-1woody2
2.4.16-1woody2
kernel-source-2.4.18
Debian:3.0
before 2.4.18-14.4, plus listed versions
2.4.18-14.3
2.4.18-14.4
kernel-image-sparc-2.4
Debian:3.0
before 26woody1, plus listed versions
26
26woody1
kernel-patch-2.4.19-mips
Debian:3.0
before 2.4.19-0.020911.1.woody5, plus listed versions
2.4.19-0.020911.1.woody4
2.4.19-0.020911.1.woody5
kernel-source-2.4.19
Debian:3.0
before 2.4.19-4.woody3, plus listed versions
2.4.19-4.woody2
2.4.19-4.woody3
kernel-source-2.4.17
Debian:3.0
before 2.4.17-1woody4, plus listed versions
2.4.17-1woody3
2.4.17-1woody4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0394 is a low vulnerability (CVSS 2.1) in Linux Kernel, published May 5, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.49%, the 42nd percentile. Fixed in kernel-source-2.4.16 2.4.16-1woody2.

References

Show 12 moreShow less
MoveEnter Open