Every CVE Search/ Get API key

CVE-2004-0519

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.2 allow remote attackers...

6.8 MediumPublic exploitFix available

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.2 allow remote attackers to execute arbitrary script as other users and possibly steal authentication information via multiple attack vectors, including the mailbox parameter in compose.php.

Exploit likelihood

22.5%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.2 allow remote attackers to execute arbitrary script as other users and possibly steal authentication information via multiple attack vectors, including the mailbox parameter in compose.php.

Record
CVE-2004-0519
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.2 allow remote attackers to execute arbitrary script as other users and possibly steal authentication information via multiple attack vectors, including the mailbox parameter in compose.php.

Record
CVE-2004-0519
Updated
2026-11-02
EUVDEUVD-2004-0518 No score

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.2 allow remote attackers to execute arbitrary script as other users and possibly steal authentication information via multiple attack vectors, including the mailbox parameter in compose.php.

Record
EUVD-2004-0518
Updated
2026-11-03
GitHub AdvisoriesGHSA-w2mg-247r-4xfc No score

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.2 allow remote attackers...

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.2 allow remote attackers to execute arbitrary script as other users and possibly steal authentication information via multiple attack vectors, including the mailbox parameter in compose.php.

Record
GHSA-w2mg-247r-4xfc
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
squirrelmail
Debian:3.0
before 1:1.2.6-1.4
1:1.2.6-1.4
squirrelmail
Red Hat:enterprise_linux:3::as
before 0:1.4.3-0.e3.1
0:1.4.3-0.e3.1
squirrelmail
Red Hat:enterprise_linux:3::desktop
before 0:1.4.3-0.e3.1
0:1.4.3-0.e3.1
squirrelmail
Red Hat:enterprise_linux:3::es
before 0:1.4.3-0.e3.1
0:1.4.3-0.e3.1
squirrelmail
Red Hat:enterprise_linux:3::ws
before 0:1.4.3-0.e3.1
0:1.4.3-0.e3.1

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, Nuclei, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0519 is a medium vulnerability (CVSS 6.8) in Squirrelmail, published June 3, 2004. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 22.5%, the 97th percentile. Fixed in squirrelmail 1:1.2.6-1.4.

References

Show 29 moreShow less
MoveEnter Open