Every CVE Search/ Get API key

CVE-2004-0564

Roaring Penguin pppoe (rp-ppoe), if installed or configured to run setuid root contrary to its...

2.1 LowFix available

Roaring Penguin pppoe (rp-ppoe), if installed or configured to run setuid root contrary to its design, allows local users to overwrite arbitrary files. NOTE: the developer has publicly disputed the claim that this is a vulnerability because pppoe "is NOT designed to run setuid-root." Therefore this identifier applies only to those configurations and installations under which pppoe is run setuid root despite the developer's warnings.

Exploit likelihood

0.36%Down 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.1

Roaring Penguin pppoe (rp-ppoe), if installed or configured to run setuid root contrary to its design, allows local users to overwrite arbitrary files. NOTE: the developer has publicly disputed the claim that this is a vulnerability because pppoe "is NOT designed to run setuid-root." Therefore this identifier applies only to those configurations and installations under which pppoe is run setuid root despite the developer's warnings.

Record
CVE-2004-0564
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Roaring Penguin pppoe (rp-ppoe), if installed or configured to run setuid root contrary to its design, allows local users to overwrite arbitrary files. NOTE: the developer has publicly disputed the claim that this is a vulnerability because pppoe "is NOT designed to run setuid-root." Therefore this identifier applies only to those configurations and installations under which pppoe is run setuid root despite the developer's warnings.

Record
CVE-2004-0564
Updated
2026-11-02
EUVDEUVD-2004-0563 No score

Roaring Penguin pppoe (rp-ppoe), if installed or configured to run setuid root contrary to its design, allows local users to overwrite arbitrary files. NOTE: the developer has publicly disputed the claim that this is a vulnerability because pppoe "is NOT designed to run setuid-root." Therefore this identifier applies only to those configurations and installations under which pppoe is run setuid root despite the developer's warnings.

Record
EUVD-2004-0563
Updated
2026-11-03
GitHub AdvisoriesGHSA-56r3-rhf9-5xfv No score

Roaring Penguin pppoe (rp-ppoe), if installed or configured to run setuid root contrary to its...

Roaring Penguin pppoe (rp-ppoe), if installed or configured to run setuid root contrary to its design, allows local users to overwrite arbitrary files. NOTE: the developer has publicly disputed the claim that this is a vulnerability because pppoe "is NOT designed to run setuid-root." Therefore this identifier applies only to those configurations and installations under which pppoe is run setuid root despite the developer's warnings.

Record
GHSA-56r3-rhf9-5xfv
Updated
2026-11-02
OSV No score

Roaring Penguin pppoe (rp-ppoe), if installed or configured to run setuid root contrary to its design, allows local users to overwrite arbitrary files. NOTE: the developer has publicly disputed the claim that this is a vulnerability because pppoe "is NOT designed to run setuid-root." Therefore this identifier applies only to those configurations and installations under which pppoe is run setuid root despite the developer's warnings.

Record
CVE-2004-0564
Updated
2026-11-02
OSVDEBIAN-CVE-2004-0564 No score

Roaring Penguin pppoe (rp-ppoe), if installed or configured to run setuid root contrary to its design, allows local users to overwrite arbitrary files. NOTE: the developer has publicly disputed the claim that this is a vulnerability because pppoe "is NOT designed to run setuid-root." Therefore this identifier applies only to those configurations and installations under which pppoe is run setuid root despite the developer's warnings.

Record
DEBIAN-CVE-2004-0564
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
rp-pppoe
Debian:12
before 3.5-4
3.5-4
rp-pppoe
Debian:13
before 3.5-4
3.5-4
rp-pppoe
Debian:14
before 3.5-4
3.5-4
rp-pppoe
Debian:3.0
before 3.3-1.2
3.3-1.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0564 is a low vulnerability (CVSS 2.1) in Roaring Penguin Pppoe, published October 4, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 30th percentile. Fixed in rp-pppoe 3.5-4.

References

MoveEnter Open