Every CVE Search/ Get API key

CVE-2004-0889

Multiple integer overflows in xpdf 3.0, and other packages that use xpdf code such as CUPS, allow...

10.0 HighFix available

Multiple integer overflows in xpdf 3.0, and other packages that use xpdf code such as CUPS, allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code, a different set of vulnerabilities than those identified by CVE-2004-0888.

Exploit likelihood

6.21%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

Multiple integer overflows in xpdf 3.0, and other packages that use xpdf code such as CUPS, allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code, a different set of vulnerabilities than those identified by CVE-2004-0888.

Record
CVE-2004-0889
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

Multiple integer overflows in xpdf 3.0, and other packages that use xpdf code such as CUPS, allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code, a different set of vulnerabilities than those identified by CVE-2004-0888.

Record
CVE-2004-0889
Updated
2026-11-02
EUVDEUVD-2004-0887 No score

Multiple integer overflows in xpdf 3.0, and other packages that use xpdf code such as CUPS, allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code, a different set of vulnerabilities than those identified by CVE-2004-0888.

Record
EUVD-2004-0887
Updated
2026-11-03
GitHub AdvisoriesGHSA-xwjm-m85h-4ff8 No score

Multiple integer overflows in xpdf 3.0, and other packages that use xpdf code such as CUPS, allow...

Multiple integer overflows in xpdf 3.0, and other packages that use xpdf code such as CUPS, allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code, a different set of vulnerabilities than those identified by CVE-2004-0888.

Record
GHSA-xwjm-m85h-4ff8
Updated
2026-11-02
OSV No score

Multiple integer overflows in xpdf 3.0, and other packages that use xpdf code such as CUPS, allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code, a different set of vulnerabilities than those identified by CVE-2004-0888.

Record
CVE-2004-0889
Updated
2026-11-02
OSVDEBIAN-CVE-2004-0889 No score

Multiple integer overflows in xpdf 3.0, and other packages that use xpdf code such as CUPS, allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code, a different set of vulnerabilities than those identified by CVE-2004-0888.

Record
DEBIAN-CVE-2004-0889
Updated
2026-11-02

Affected products

Show 4 moreShow less

Affected packages

Affected packages
PackageAffectedFixed
xpdf
Debian:12
before 3.00-10
3.00-10
xpdf
Debian:13
before 3.00-10
3.00-10
xpdf
Debian:14
before 3.00-10
3.00-10

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0889 is a high vulnerability (CVSS 10.0) in Easy Software Products Cups, published October 26, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.21%, the 93rd percentile. Fixed in xpdf 3.00-10.

References

MoveEnter Open