Every CVE Search/ Get API key

CVE-2004-0940

Buffer overflow in the get_tag function in mod_include for Apache 1.3.x to 1.3.32 allows local...

7.8 HighPublic exploitFix available

Buffer overflow in the get_tag function in mod_include for Apache 1.3.x to 1.3.32 allows local users who can create SSI documents to execute arbitrary code as the apache user via SSI (XSSI) documents that trigger a length calculation error.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

4.83%Down 2.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

Buffer overflow in the get_tag function in mod_include for Apache 1.3.x to 1.3.32 allows local users who can create SSI documents to execute arbitrary code as the apache user via SSI (XSSI) documents that trigger a length calculation error.

Record
CVE-2004-0940
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.9 MediumAV:L/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-131
Updated
2026-11-02
CVE List No score

Buffer overflow in the get_tag function in mod_include for Apache 1.3.x to 1.3.32 allows local users who can create SSI documents to execute arbitrary code as the apache user via SSI (XSSI) documents that trigger a length calculation error.

Record
CVE-2004-0940
Updated
2026-11-02
EUVDEUVD-2004-0938 No score

Buffer overflow in the get_tag function in mod_include for Apache 1.3.x to 1.3.32 allows local users who can create SSI documents to execute arbitrary code as the apache user via SSI (XSSI) documents that trigger a length calculation error.

Record
EUVD-2004-0938
Updated
2026-11-03
GitHub AdvisoriesGHSA-cx2h-jfxr-vw9c 7.8

Buffer overflow in the get_tag function in mod_include for Apache 1.3.x to 1.3.32 allows local...

Buffer overflow in the get_tag function in mod_include for Apache 1.3.x to 1.3.32 allows local users who can create SSI documents to execute arbitrary code as the apache user via SSI (XSSI) documents that trigger a length calculation error.

Record
GHSA-cx2h-jfxr-vw9c
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119, CWE-131
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apache
Debian:3.0
before 1.3.26-0woody6
1.3.26-0woody6

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBApache 1.3.x mod_include - Local Buffer Overflow2004-10-18
Exploit-DBApache 1.3.31 mod_include - Local Buffer Overflow2004-10-21

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0940 is a high vulnerability (CVSS 7.8) in Apache Http Server, published October 26, 2004. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 4.83%, the 92nd percentile. Fixed in apache 1.3.26-0woody6.

References

Show 24 moreShow less
MoveEnter Open