Every CVE Search/ Get API key

CVE-2004-0941

Multiple buffer overflows in the gd graphics library (libgd) 2.0.21 and earlier may allow remote...

10.0 HighFix available

Multiple buffer overflows in the gd graphics library (libgd) 2.0.21 and earlier may allow remote attackers to execute arbitrary code via malformed image files that trigger the overflows due to improper calls to the gdMalloc function, a different set of vulnerabilities than CVE-2004-0990.

Exploit likelihood

10.7%Down 1.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

Multiple buffer overflows in the gd graphics library (libgd) 2.0.21 and earlier may allow remote attackers to execute arbitrary code via malformed image files that trigger the overflows due to improper calls to the gdMalloc function, a different set of vulnerabilities than CVE-2004-0990.

Record
CVE-2004-0941
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

Multiple buffer overflows in the gd graphics library (libgd) 2.0.21 and earlier may allow remote attackers to execute arbitrary code via malformed image files that trigger the overflows due to improper calls to the gdMalloc function, a different set of vulnerabilities than CVE-2004-0990.

Record
CVE-2004-0941
Updated
2026-11-02
EUVDEUVD-2004-0939 No score

Multiple buffer overflows in the gd graphics library (libgd) 2.0.21 and earlier may allow remote attackers to execute arbitrary code via malformed image files that trigger the overflows due to improper calls to the gdMalloc function, a different set of vulnerabilities than CVE-2004-0990.

Record
EUVD-2004-0939
Updated
2026-11-03
GitHub AdvisoriesGHSA-5jw2-pr8r-5fc7 No score

Multiple buffer overflows in the gd graphics library (libgd) 2.0.21 and earlier may allow remote...

Multiple buffer overflows in the gd graphics library (libgd) 2.0.21 and earlier may allow remote attackers to execute arbitrary code via malformed image files that trigger the overflows due to improper calls to the gdMalloc function, a different set of vulnerabilities than CVE-2004-0990.

Record
GHSA-5jw2-pr8r-5fc7
Updated
2026-11-02
OSV No score

Multiple buffer overflows in the gd graphics library (libgd) 2.0.21 and earlier may allow remote attackers to execute arbitrary code via malformed image files that trigger the overflows due to improper calls to the gdMalloc function, a different set of vulnerabilities than CVE-2004-0990.

Record
CVE-2004-0941
Updated
2026-11-02
OSVDEBIAN-CVE-2004-0941 No score

Multiple buffer overflows in the gd graphics library (libgd) 2.0.21 and earlier may allow remote attackers to execute arbitrary code via malformed image files that trigger the overflows due to improper calls to the gdMalloc function, a different set of vulnerabilities than CVE-2004-0990.

Record
DEBIAN-CVE-2004-0941
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libgd2
Debian:12
before 2.0.33-1.1
2.0.33-1.1
libgd2
Debian:13
before 2.0.33-1.1
2.0.33-1.1
libgd2
Debian:14
before 2.0.33-1.1
2.0.33-1.1
libgd
Debian:3.0
From an advisory covering 2 CVEs
before 1.8.4-17.woody4, plus listed versions
1.8.4-17.woody2
1.8.4-17.woody4
libgd2
Debian:3.0
From an advisory covering 2 CVEs
before 2.0.1-10woody2
2.0.1-10woody2
gd
Red Hat:enterprise_linux:3::as
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
gd-debuginfo
Red Hat:enterprise_linux:3::as
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
gd-devel
Red Hat:enterprise_linux:3::as
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
gd-progs
Red Hat:enterprise_linux:3::as
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
gd
Red Hat:enterprise_linux:3::desktop
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
Show 27 moreShow less
Affected packages
PackageAffectedFixed
gd-debuginfo
Red Hat:enterprise_linux:3::desktop
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
gd-devel
Red Hat:enterprise_linux:3::desktop
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
gd-progs
Red Hat:enterprise_linux:3::desktop
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
gd
Red Hat:enterprise_linux:3::es
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
gd-debuginfo
Red Hat:enterprise_linux:3::es
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
gd-devel
Red Hat:enterprise_linux:3::es
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
gd-progs
Red Hat:enterprise_linux:3::es
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
gd
Red Hat:enterprise_linux:3::ws
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
gd-debuginfo
Red Hat:enterprise_linux:3::ws
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
gd-devel
Red Hat:enterprise_linux:3::ws
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
gd-progs
Red Hat:enterprise_linux:3::ws
From an advisory covering 2 CVEs
before 0:1.8.4-12.3.1
0:1.8.4-12.3.1
gd
Red Hat:enterprise_linux:4::as
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1
gd-debuginfo
Red Hat:enterprise_linux:4::as
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1
gd-devel
Red Hat:enterprise_linux:4::as
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1
gd-progs
Red Hat:enterprise_linux:4::as
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1
gd
Red Hat:enterprise_linux:4::desktop
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1
gd-debuginfo
Red Hat:enterprise_linux:4::desktop
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1
gd-devel
Red Hat:enterprise_linux:4::desktop
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1
gd-progs
Red Hat:enterprise_linux:4::desktop
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1
gd
Red Hat:enterprise_linux:4::es
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1
gd-debuginfo
Red Hat:enterprise_linux:4::es
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1
gd-devel
Red Hat:enterprise_linux:4::es
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1
gd-progs
Red Hat:enterprise_linux:4::es
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1
gd
Red Hat:enterprise_linux:4::ws
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1
gd-debuginfo
Red Hat:enterprise_linux:4::ws
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1
gd-devel
Red Hat:enterprise_linux:4::ws
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1
gd-progs
Red Hat:enterprise_linux:4::ws
before 0:2.0.28-4.4E.1
0:2.0.28-4.4E.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0941 is a high vulnerability (CVSS 10.0) in Gd Graphics Library Gdlib, published November 19, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 10.7%, the 95th percentile. Fixed in libgd2 2.0.33-1.1.

References

Show 29 moreShow less
MoveEnter Open