CVE-2004-1005
Multiple buffer overflows in Midnight Commander (mc) 4.5.55 and earlier allow remote attackers to...
Multiple buffer overflows in Midnight Commander (mc) 4.5.55 and earlier allow remote attackers to have an unknown impact.
Exploit likelihood
What each source reports
NVD Score used
7.5
Multiple buffer overflows in Midnight Commander (mc) 4.5.55 and earlier allow remote attackers to have an unknown impact.
- Record
CVE-2004-1005- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Multiple buffer overflows in Midnight Commander (mc) 4.5.55 and earlier allow remote attackers to have an unknown impact.
- Record
CVE-2004-1005- Updated
- 2026-11-02
EUVDEUVD-2004-1003 No score
Multiple buffer overflows in Midnight Commander (mc) 4.5.55 and earlier allow remote attackers to have an unknown impact.
- Record
EUVD-2004-1003- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wvrq-8gxp-x8hr No score
Multiple buffer overflows in Midnight Commander (mc) 4.5.55 and earlier allow remote attackers to...
Multiple buffer overflows in Midnight Commander (mc) 4.5.55 and earlier allow remote attackers to have an unknown impact.
- Record
GHSA-wvrq-8gxp-x8hr- Updated
- 2026-11-02
OSV No score
Multiple buffer overflows in Midnight Commander (mc) 4.5.55 and earlier allow remote attackers to have an unknown impact.
- Record
CVE-2004-1005- Updated
- 2026-11-02
OSVDEBIAN-CVE-2004-1005 No score
Multiple buffer overflows in Midnight Commander (mc) 4.5.55 and earlier allow remote attackers to have an unknown impact.
- Record
DEBIAN-CVE-2004-1005- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mcDebian:12 |
before 1:4.6.0-4.6.1-pre3-1 | 1:4.6.0-4.6.1-pre3-1 |
mcDebian:13 |
before 1:4.6.0-4.6.1-pre3-1 | 1:4.6.0-4.6.1-pre3-1 |
mcDebian:14 |
before 1:4.6.0-4.6.1-pre3-1 | 1:4.6.0-4.6.1-pre3-1 |
mcDebian:3.0 |
before 4.5.55-1.2woody5, plus listed versions 4.5.55-1.2woody3 |
4.5.55-1.2woody5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2004-1005 is a high vulnerability (CVSS 7.5) in Midnight Commander Commander, published January 14, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.79%, the 78th percentile. Fixed in mc 1:4.6.0-4.6.1-pre3-1.
References
secunia.com/advisories/13863
exchange.xforce.ibmcloud.com/vulnerabilities/18898
redhat.com/support/errata/RHSA-2005-217.html
debian.org/security/2005/dsa-639
gentoo.org/security/en/glsa/glsa-200502-24.xml
nvd.nist.gov/vuln/detail/CVE-2004-1005
github.com/advisories/GHSA-wvrq-8gxp-x8hr
security-tracker.debian.org/tracker/CVE-2004-1005