Every CVE Search/ Get API key

CVE-2004-1076

Multiple buffer overflows in the RtConfigLoad function in rt-config.c for Atari800 before 1.3.4...

7.2 HighFix available

Multiple buffer overflows in the RtConfigLoad function in rt-config.c for Atari800 before 1.3.4 allow local users to execute arbitrary code via large values in the configuration file.

Exploit likelihood

0.65%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.2

Multiple buffer overflows in the RtConfigLoad function in rt-config.c for Atari800 before 1.3.4 allow local users to execute arbitrary code via large values in the configuration file.

Record
CVE-2004-1076
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

Multiple buffer overflows in the RtConfigLoad function in rt-config.c for Atari800 before 1.3.4 allow local users to execute arbitrary code via large values in the configuration file.

Record
CVE-2004-1076
Updated
2026-11-02
EUVDEUVD-2004-1074 No score

Multiple buffer overflows in the RtConfigLoad function in rt-config.c for Atari800 before 1.3.4 allow local users to execute arbitrary code via large values in the configuration file.

Record
EUVD-2004-1074
Updated
2026-11-03
GitHub AdvisoriesGHSA-grj9-cjg3-cr7m No score

Multiple buffer overflows in the RtConfigLoad function in rt-config.c for Atari800 before 1.3.4...

Multiple buffer overflows in the RtConfigLoad function in rt-config.c for Atari800 before 1.3.4 allow local users to execute arbitrary code via large values in the configuration file.

Record
GHSA-grj9-cjg3-cr7m
Updated
2026-11-02
OSV No score

Multiple buffer overflows in the RtConfigLoad function in rt-config.c for Atari800 before 1.3.4 allow local users to execute arbitrary code via large values in the configuration file.

Record
CVE-2004-1076
Updated
2026-11-02
OSVDEBIAN-CVE-2004-1076 No score

Multiple buffer overflows in the RtConfigLoad function in rt-config.c for Atari800 before 1.3.4 allow local users to execute arbitrary code via large values in the configuration file.

Record
DEBIAN-CVE-2004-1076
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
atari800
Debian:12
before 1.3.2-1, plus listed versions
0.6.2-10.8.6-20.9.8a-21.2.2-1woody3
1.3.2-1
atari800
Debian:13
before 1.3.2-1, plus listed versions
0.6.2-10.8.6-20.9.8a-21.2.2-1woody3
1.3.2-1
atari800
Debian:14
before 1.3.2-1, plus listed versions
0.6.2-10.8.6-20.9.8a-21.2.2-1woody3
1.3.2-1
atari800
Debian:3.0
before 1.2.2-1woody3, plus listed versions
0.6.2-10.8.6-20.9.8a-2
1.2.2-1woody3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-1076 is a high vulnerability (CVSS 7.2) in Atari800, published December 8, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.65%, the 51st percentile. Fixed in atari800 1.3.2-1.

References

Show 4 moreShow less
MoveEnter Open