Every CVE Search/ Get API key

CVE-2004-1145

Multiple vulnerabilities in Konqueror in KDE 3.3.1 and earlier (1) allow access to restricted...

5.0 MediumFix available

CVE-2004-1145 is a medium vulnerability (CVSS 5.0) in Altlinux Alt Linux, published December 15, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.13%, the 90th percentile. Fixed in kdelibs 6:3.3.1-3.3.

Multiple vulnerabilities in Konqueror in KDE 3.3.1 and earlier (1) allow access to restricted Java classes via JavaScript and (2) do not properly restrict access to certain Java classes from the Java applet, which allows remote attackers to bypass sandbox restrictions and read or write arbitrary files.

Exploit likelihood

4.13%Up 2.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Multiple vulnerabilities in Konqueror in KDE 3.3.1 and earlier (1) allow access to restricted Java classes via JavaScript and (2) do not properly restrict access to certain Java classes from the Java applet, which allows remote attackers to bypass sandbox restrictions and read or write arbitrary files.

Record
CVE-2004-1145
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Multiple vulnerabilities in Konqueror in KDE 3.3.1 and earlier (1) allow access to restricted Java classes via JavaScript and (2) do not properly restrict access to certain Java classes from the Java applet, which allows remote attackers to bypass sandbox restrictions and read or write arbitrary files.

Record
CVE-2004-1145
Updated
2026-11-02
EUVDEUVD-2004-1143 No score

Multiple vulnerabilities in Konqueror in KDE 3.3.1 and earlier (1) allow access to restricted Java classes via JavaScript and (2) do not properly restrict access to certain Java classes from the Java applet, which allows remote attackers to bypass sandbox restrictions and read or write arbitrary files.

Record
EUVD-2004-1143
Updated
2026-11-03
GitHub AdvisoriesGHSA-95hh-399q-cvw3 No score

Multiple vulnerabilities in Konqueror in KDE 3.3.1 and earlier (1) allow access to restricted...

Multiple vulnerabilities in Konqueror in KDE 3.3.1 and earlier (1) allow access to restricted Java classes via JavaScript and (2) do not properly restrict access to certain Java classes from the Java applet, which allows remote attackers to bypass sandbox restrictions and read or write arbitrary files.

Record
GHSA-95hh-399q-cvw3
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
kdelibs
Red Hat:enterprise_linux:4::as
before 6:3.3.1-3.3
6:3.3.1-3.3
kdelibs-debuginfo
Red Hat:enterprise_linux:4::as
before 6:3.3.1-3.3
6:3.3.1-3.3
kdelibs-devel
Red Hat:enterprise_linux:4::as
before 6:3.3.1-3.3
6:3.3.1-3.3
kdelibs
Red Hat:enterprise_linux:4::desktop
before 6:3.3.1-3.3
6:3.3.1-3.3
kdelibs-debuginfo
Red Hat:enterprise_linux:4::desktop
before 6:3.3.1-3.3
6:3.3.1-3.3
kdelibs-devel
Red Hat:enterprise_linux:4::desktop
before 6:3.3.1-3.3
6:3.3.1-3.3
kdelibs
Red Hat:enterprise_linux:4::es
before 6:3.3.1-3.3
6:3.3.1-3.3
kdelibs-debuginfo
Red Hat:enterprise_linux:4::es
before 6:3.3.1-3.3
6:3.3.1-3.3
kdelibs-devel
Red Hat:enterprise_linux:4::es
before 6:3.3.1-3.3
6:3.3.1-3.3
kdelibs
Red Hat:enterprise_linux:4::ws
before 6:3.3.1-3.3
6:3.3.1-3.3
kdelibs-debuginfo
Red Hat:enterprise_linux:4::ws
before 6:3.3.1-3.3
6:3.3.1-3.3
kdelibs-devel
Red Hat:enterprise_linux:4::ws
before 6:3.3.1-3.3
6:3.3.1-3.3

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 19 moreShow less
MoveEnter Open