Every CVE Search/ Get API key

CVE-2004-1176

Buffer underflow in extfs.c in Midnight Commander (mc) 4.5.55 and earlier allows remote attackers...

7.5 HighFix available

Buffer underflow in extfs.c in Midnight Commander (mc) 4.5.55 and earlier allows remote attackers to cause a denial of service and possibly execute arbitrary code.

Exploit likelihood

3.10%Down 2.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Buffer underflow in extfs.c in Midnight Commander (mc) 4.5.55 and earlier allows remote attackers to cause a denial of service and possibly execute arbitrary code.

Record
CVE-2004-1176
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Buffer underflow in extfs.c in Midnight Commander (mc) 4.5.55 and earlier allows remote attackers to cause a denial of service and possibly execute arbitrary code.

Record
CVE-2004-1176
Updated
2026-11-02
EUVDEUVD-2004-1174 No score

Buffer underflow in extfs.c in Midnight Commander (mc) 4.5.55 and earlier allows remote attackers to cause a denial of service and possibly execute arbitrary code.

Record
EUVD-2004-1174
Updated
2026-11-03
GitHub AdvisoriesGHSA-6j4g-wprm-mhpw No score

Buffer underflow in extfs.c in Midnight Commander (mc) 4.5.55 and earlier allows remote attackers...

Buffer underflow in extfs.c in Midnight Commander (mc) 4.5.55 and earlier allows remote attackers to cause a denial of service and possibly execute arbitrary code.

Record
GHSA-6j4g-wprm-mhpw
Updated
2026-11-02
OSV No score

Buffer underflow in extfs.c in Midnight Commander (mc) 4.5.55 and earlier allows remote attackers to cause a denial of service and possibly execute arbitrary code.

Record
CVE-2004-1176
Updated
2026-11-02
OSVDEBIAN-CVE-2004-1176 No score

Buffer underflow in extfs.c in Midnight Commander (mc) 4.5.55 and earlier allows remote attackers to cause a denial of service and possibly execute arbitrary code.

Record
DEBIAN-CVE-2004-1176
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mc
Debian:12
before 1:4.6.0-4.6.1-pre3-1
1:4.6.0-4.6.1-pre3-1
mc
Debian:13
before 1:4.6.0-4.6.1-pre3-1
1:4.6.0-4.6.1-pre3-1
mc
Debian:14
before 1:4.6.0-4.6.1-pre3-1
1:4.6.0-4.6.1-pre3-1
mc
Debian:3.0
before 4.5.55-1.2woody5, plus listed versions
4.5.55-1.2woody3
4.5.55-1.2woody5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-1176 is a high vulnerability (CVSS 7.5) in Midnight Commander Commander, published January 14, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.10%, the 87th percentile. Fixed in mc 1:4.6.0-4.6.1-pre3-1.

References

MoveEnter Open