Every CVE Search/ Get API key

CVE-2004-1377

The (1) fixps (aka fixps.in) and (2) psmandup (aka psmandup.in) scripts in a2ps before 4.13 allow...

2.1 LowFix available

The (1) fixps (aka fixps.in) and (2) psmandup (aka psmandup.in) scripts in a2ps before 4.13 allow local users to overwrite arbitrary files via a symlink attack on temporary files.

Exploit likelihood

0.36%Down 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.1

The (1) fixps (aka fixps.in) and (2) psmandup (aka psmandup.in) scripts in a2ps before 4.13 allow local users to overwrite arbitrary files via a symlink attack on temporary files.

Record
CVE-2004-1377
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

The (1) fixps (aka fixps.in) and (2) psmandup (aka psmandup.in) scripts in a2ps before 4.13 allow local users to overwrite arbitrary files via a symlink attack on temporary files.

Record
CVE-2004-1377
Updated
2026-11-02
EUVDEUVD-2004-1374 No score

The (1) fixps (aka fixps.in) and (2) psmandup (aka psmandup.in) scripts in a2ps before 4.13 allow local users to overwrite arbitrary files via a symlink attack on temporary files.

Record
EUVD-2004-1374
Updated
2026-11-03
GitHub AdvisoriesGHSA-gjhg-g59h-c3r3 No score

The (1) fixps (aka fixps.in) and (2) psmandup (aka psmandup.in) scripts in a2ps before 4.13 allow...

The (1) fixps (aka fixps.in) and (2) psmandup (aka psmandup.in) scripts in a2ps before 4.13 allow local users to overwrite arbitrary files via a symlink attack on temporary files.

Record
GHSA-gjhg-g59h-c3r3
Updated
2026-11-02
OSV No score

The (1) fixps (aka fixps.in) and (2) psmandup (aka psmandup.in) scripts in a2ps before 4.13 allow local users to overwrite arbitrary files via a symlink attack on temporary files.

Record
CVE-2004-1377
Updated
2026-11-02
OSVDEBIAN-CVE-2004-1377 No score

The (1) fixps (aka fixps.in) and (2) psmandup (aka psmandup.in) scripts in a2ps before 4.13 allow local users to overwrite arbitrary files via a symlink attack on temporary files.

Record
DEBIAN-CVE-2004-1377
Updated
2026-11-02
OSVopenSUSE-SU-2024:10086-1 No score

a2ps-4.14-6.6 on GA media

These are all security issues fixed in the a2ps-4.14-6.6 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10086-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
a2ps
Debian:12
before 1:4.13b-4.3
1:4.13b-4.3
a2ps
Debian:13
before 1:4.13b-4.3
1:4.13b-4.3
a2ps
Debian:14
before 1:4.13b-4.3
1:4.13b-4.3
a2ps
openSUSE:Tumbleweed
before 4.14-6.6
4.14-6.6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-1377 is a low vulnerability (CVSS 2.1) in Gnu A2ps, published December 27, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 30th percentile. Fixed in a2ps 1:4.13b-4.3.

References

Show 6 moreShow less
MoveEnter Open