Every CVE Search/ Get API key

CVE-2004-1379

Heap-based buffer overflow in the DVD subpicture decoder in xine xine-lib 1-rc5 and earlier...

7.5 HighFix available

Heap-based buffer overflow in the DVD subpicture decoder in xine xine-lib 1-rc5 and earlier allows remote attackers to execute arbitrary code via a (1) DVD or (2) MPEG subpicture header where the second field reuses RLE data from the end of the first field.

Exploit likelihood

4.00%Down 4.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Heap-based buffer overflow in the DVD subpicture decoder in xine xine-lib 1-rc5 and earlier allows remote attackers to execute arbitrary code via a (1) DVD or (2) MPEG subpicture header where the second field reuses RLE data from the end of the first field.

Record
CVE-2004-1379
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in the DVD subpicture decoder in xine xine-lib 1-rc5 and earlier allows remote attackers to execute arbitrary code via a (1) DVD or (2) MPEG subpicture header where the second field reuses RLE data from the end of the first field.

Record
CVE-2004-1379
Updated
2026-11-02
EUVDEUVD-2004-1376 No score

Heap-based buffer overflow in the DVD subpicture decoder in xine xine-lib 1-rc5 and earlier allows remote attackers to execute arbitrary code via a (1) DVD or (2) MPEG subpicture header where the second field reuses RLE data from the end of the first field.

Record
EUVD-2004-1376
Updated
2026-11-03
GitHub AdvisoriesGHSA-p6pq-vqh3-43xp No score

Heap-based buffer overflow in the DVD subpicture decoder in xine xine-lib 1-rc5 and earlier...

Heap-based buffer overflow in the DVD subpicture decoder in xine xine-lib 1-rc5 and earlier allows remote attackers to execute arbitrary code via a (1) DVD or (2) MPEG subpicture header where the second field reuses RLE data from the end of the first field.

Record
GHSA-p6pq-vqh3-43xp
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xine-lib
Debian:3.0
before 0.9.8-2woody2, plus listed versions
0.9.8-2
0.9.8-2woody2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-1379 is a high vulnerability (CVSS 7.5) in Xine, published September 16, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.00%, the 90th percentile. Fixed in xine-lib 0.9.8-2woody2.

References

Show 4 moreShow less
MoveEnter Open