Every CVE Search/ Get API key

CVE-2004-1388

Format string vulnerability in the gpsd_report function for BerliOS GPD daemon (gpsd, formerly...

7.5 HighPublic exploitFix available

Format string vulnerability in the gpsd_report function for BerliOS GPD daemon (gpsd, formerly pygps) 1.9.0 through 2.7 allows remote attackers to execute arbitrary code via certain GPS requests containing format string specifiers that are not properly handled in syslog calls.

Exploit likelihood

68.2%Down 11.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Format string vulnerability in the gpsd_report function for BerliOS GPD daemon (gpsd, formerly pygps) 1.9.0 through 2.7 allows remote attackers to execute arbitrary code via certain GPS requests containing format string specifiers that are not properly handled in syslog calls.

Record
CVE-2004-1388
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Format string vulnerability in the gpsd_report function for BerliOS GPD daemon (gpsd, formerly pygps) 1.9.0 through 2.7 allows remote attackers to execute arbitrary code via certain GPS requests containing format string specifiers that are not properly handled in syslog calls.

Record
CVE-2004-1388
Updated
2026-11-02
EUVDEUVD-2004-1385 No score

Format string vulnerability in the gpsd_report function for BerliOS GPD daemon (gpsd, formerly pygps) 1.9.0 through 2.7 allows remote attackers to execute arbitrary code via certain GPS requests containing format string specifiers that are not properly handled in syslog calls.

Record
EUVD-2004-1385
Updated
2026-11-03
GitHub AdvisoriesGHSA-6g3h-vj3c-7f68 No score

Format string vulnerability in the gpsd_report function for BerliOS GPD daemon (gpsd, formerly...

Format string vulnerability in the gpsd_report function for BerliOS GPD daemon (gpsd, formerly pygps) 1.9.0 through 2.7 allows remote attackers to execute arbitrary code via certain GPS requests containing format string specifiers that are not properly handled in syslog calls.

Record
GHSA-6g3h-vj3c-7f68
Updated
2026-11-02
OSV No score

Format string vulnerability in the gpsd_report function for BerliOS GPD daemon (gpsd, formerly pygps) 1.9.0 through 2.7 allows remote attackers to execute arbitrary code via certain GPS requests containing format string specifiers that are not properly handled in syslog calls.

Record
CVE-2004-1388
Updated
2026-11-02
OSVDEBIAN-CVE-2004-1388 No score

Format string vulnerability in the gpsd_report function for BerliOS GPD daemon (gpsd, formerly pygps) 1.9.0 through 2.7 allows remote attackers to execute arbitrary code via certain GPS requests containing format string specifiers that are not properly handled in syslog calls.

Record
DEBIAN-CVE-2004-1388
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gpsd
Debian:12
before 2.7-4
2.7-4
gpsd
Debian:13
before 2.7-4
2.7-4
gpsd
Debian:14
before 2.7-4
2.7-4

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-1388 is a high vulnerability (CVSS 7.5) in Berlios Gps Daemon, published December 31, 2004. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 68.2%, the 99th percentile. Fixed in gpsd 2.7-4.

References

MoveEnter Open