Every CVE Search/ Get API key

CVE-2004-1617

Lynx, lynx-ssl, and lynx-cur before 2.8.6dev.8 allow remote attackers to cause a denial of...

5.0 MediumFix available

Lynx, lynx-ssl, and lynx-cur before 2.8.6dev.8 allow remote attackers to cause a denial of service (infinite loop) via a web page or HTML email that contains invalid HTML including (1) a TEXTAREA tag with a large COLS value and (2) a large tag name in an element that is not terminated, as demonstrated by mangleme. NOTE: a followup suggests that the relevant trigger for this issue is the large COLS value.

Exploit likelihood

3.75%Up 1.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Lynx, lynx-ssl, and lynx-cur before 2.8.6dev.8 allow remote attackers to cause a denial of service (infinite loop) via a web page or HTML email that contains invalid HTML including (1) a TEXTAREA tag with a large COLS value and (2) a large tag name in an element that is not terminated, as demonstrated by mangleme. NOTE: a followup suggests that the relevant trigger for this issue is the large COLS value.

Record
CVE-2004-1617
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Lynx, lynx-ssl, and lynx-cur before 2.8.6dev.8 allow remote attackers to cause a denial of service (infinite loop) via a web page or HTML email that contains invalid HTML including (1) a TEXTAREA tag with a large COLS value and (2) a large tag name in an element that is not terminated, as demonstrated by mangleme. NOTE: a followup suggests that the relevant trigger for this issue is the large COLS value.

Record
CVE-2004-1617
Updated
2026-11-02
EUVDEUVD-2004-1611 No score

Lynx, lynx-ssl, and lynx-cur before 2.8.6dev.8 allow remote attackers to cause a denial of service (infinite loop) via a web page or HTML email that contains invalid HTML including (1) a TEXTAREA tag with a large COLS value and (2) a large tag name in an element that is not terminated, as demonstrated by mangleme. NOTE: a followup suggests that the relevant trigger for this issue is the large COLS value.

Record
EUVD-2004-1611
Updated
2026-11-03
GitHub AdvisoriesGHSA-j8fp-ff64-g7r6 No score

Lynx, lynx-ssl, and lynx-cur before 2.8.6dev.8 allow remote attackers to cause a denial of...

Lynx, lynx-ssl, and lynx-cur before 2.8.6dev.8 allow remote attackers to cause a denial of service (infinite loop) via a web page or HTML email that contains invalid HTML including (1) a TEXTAREA tag with a large COLS value and (2) a large tag name in an element that is not terminated, as demonstrated by mangleme. NOTE: a followup suggests that the relevant trigger for this issue is the large COLS value.

Record
GHSA-j8fp-ff64-g7r6
Weakness
CWE-20
Updated
2026-11-02
OSV No score

Lynx, lynx-ssl, and lynx-cur before 2.8.6dev.8 allow remote attackers to cause a denial of service (infinite loop) via a web page or HTML email that contains invalid HTML including (1) a TEXTAREA tag with a large COLS value and (2) a large tag name in an element that is not terminated, as demonstrated by mangleme. NOTE: a followup suggests that the relevant trigger for this issue is the large COLS value.

Record
CVE-2004-1617
Updated
2026-11-02
OSVDEBIAN-CVE-2004-1617 No score

Lynx, lynx-ssl, and lynx-cur before 2.8.6dev.8 allow remote attackers to cause a denial of service (infinite loop) via a web page or HTML email that contains invalid HTML including (1) a TEXTAREA tag with a large COLS value and (2) a large tag name in an element that is not terminated, as demonstrated by mangleme. NOTE: a followup suggests that the relevant trigger for this issue is the large COLS value.

Record
DEBIAN-CVE-2004-1617
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lynx
Debian:12
before 2.8.5-2sarge1.2
2.8.5-2sarge1.2
lynx
Debian:13
before 2.8.5-2sarge1.2
2.8.5-2sarge1.2
lynx
Debian:14
before 2.8.5-2sarge1.2
2.8.5-2sarge1.2
lynx
Debian:3.0
before 2.8.4.1b-3.4, plus listed versions
2.8.4.1b-3.22.8.4.1b-3.3
2.8.4.1b-3.4
lynx
Debian:3.1
before 2.8.5-2sarge2, plus listed versions
2.8.5-22.8.5-2sarge12.8.5-2sarge1.12.8.5-2sarge1.2
2.8.5-2sarge2
lynx-ssl
Debian:3.0
before 1:2.8.4.1b-3.3, plus listed versions
1:2.8.4.1b-31:2.8.4.1b-3.11:2.8.4.1b-3.22.8.3.1-12.8.3.1-1.1
1:2.8.4.1b-3.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-1617 is a medium vulnerability (CVSS 5.0) in University Of Kansas Lynx, published October 18, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.75%, the 89th percentile. Fixed in lynx 2.8.5-2sarge1.2.

References

Show 8 moreShow less
MoveEnter Open