Every CVE Search/ Get API key

CVE-2004-2027

Buffer overflow in Icecast 2.0.0 and earlier allows remote attackers to cause a denial of service...

5.0 MediumFix available

Buffer overflow in Icecast 2.0.0 and earlier allows remote attackers to cause a denial of service (crash) via a long Basic Authorization header that triggers an out-of-bounds read.

Exploit likelihood

2.08%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Buffer overflow in Icecast 2.0.0 and earlier allows remote attackers to cause a denial of service (crash) via a long Basic Authorization header that triggers an out-of-bounds read.

Record
CVE-2004-2027
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

Buffer overflow in Icecast 2.0.0 and earlier allows remote attackers to cause a denial of service (crash) via a long Basic Authorization header that triggers an out-of-bounds read.

Record
CVE-2004-2027
Updated
2026-11-02
EUVDEUVD-2004-2019 No score

Buffer overflow in Icecast 2.0.0 and earlier allows remote attackers to cause a denial of service (crash) via a long Basic Authorization header that triggers an out-of-bounds read.

Record
EUVD-2004-2019
Updated
2026-11-03
GitHub AdvisoriesGHSA-29fv-34jg-3cfg No score

Buffer overflow in Icecast 2.0.0 and earlier allows remote attackers to cause a denial of service...

Buffer overflow in Icecast 2.0.0 and earlier allows remote attackers to cause a denial of service (crash) via a long Basic Authorization header that triggers an out-of-bounds read.

Record
GHSA-29fv-34jg-3cfg
Updated
2026-11-02
OSV No score

Buffer overflow in Icecast 2.0.0 and earlier allows remote attackers to cause a denial of service (crash) via a long Basic Authorization header that triggers an out-of-bounds read.

Record
CVE-2004-2027
Updated
2026-11-02
OSVDEBIAN-CVE-2004-2027 No score

Buffer overflow in Icecast 2.0.0 and earlier allows remote attackers to cause a denial of service (crash) via a long Basic Authorization header that triggers an out-of-bounds read.

Record
DEBIAN-CVE-2004-2027
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
icecast2
Debian:12
before 2.0.1.debian-1
2.0.1.debian-1
icecast2
Debian:13
before 2.0.1.debian-1
2.0.1.debian-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-2027 is a medium vulnerability (CVSS 5.0) in Icecast, published May 10, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.08%, the 81st percentile. Fixed in icecast2 2.0.1.debian-1.

References

Show 4 moreShow less
MoveEnter Open