Every CVE Search/ Get API key

CVE-2004-2167

Multiple buffer overflows in LaTeX2rtf 1.9.15, and possibly other versions, allow remote...

7.5 HighPublic exploitFix available

Multiple buffer overflows in LaTeX2rtf 1.9.15, and possibly other versions, allow remote attackers to execute arbitrary code via (1) the expandmacro function, and possibly (2) Environments and (3) TranslateCommand.

Exploit likelihood

14.3%Down 36.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Multiple buffer overflows in LaTeX2rtf 1.9.15, and possibly other versions, allow remote attackers to execute arbitrary code via (1) the expandmacro function, and possibly (2) Environments and (3) TranslateCommand.

Record
CVE-2004-2167
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Multiple buffer overflows in LaTeX2rtf 1.9.15, and possibly other versions, allow remote attackers to execute arbitrary code via (1) the expandmacro function, and possibly (2) Environments and (3) TranslateCommand.

Record
CVE-2004-2167
Updated
2026-11-02
EUVDEUVD-2004-2159 No score

Multiple buffer overflows in LaTeX2rtf 1.9.15, and possibly other versions, allow remote attackers to execute arbitrary code via (1) the expandmacro function, and possibly (2) Environments and (3) TranslateCommand.

Record
EUVD-2004-2159
Updated
2026-11-03
GitHub AdvisoriesGHSA-ww4g-p7g5-wh4f No score

Multiple buffer overflows in LaTeX2rtf 1.9.15, and possibly other versions, allow remote...

Multiple buffer overflows in LaTeX2rtf 1.9.15, and possibly other versions, allow remote attackers to execute arbitrary code via (1) the expandmacro function, and possibly (2) Environments and (3) TranslateCommand.

Record
GHSA-ww4g-p7g5-wh4f
Updated
2026-11-02
OSV No score

Multiple buffer overflows in LaTeX2rtf 1.9.15, and possibly other versions, allow remote attackers to execute arbitrary code via (1) the expandmacro function, and possibly (2) Environments and (3) TranslateCommand.

Record
CVE-2004-2167
Updated
2026-11-02
OSVDEBIAN-CVE-2004-2167 No score

Multiple buffer overflows in LaTeX2rtf 1.9.15, and possibly other versions, allow remote attackers to execute arbitrary code via (1) the expandmacro function, and possibly (2) Environments and (3) TranslateCommand.

Record
DEBIAN-CVE-2004-2167
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
latex2rtf
Debian:12
before 1.9.16
1.9.16
latex2rtf
Debian:13
before 1.9.16
1.9.16
latex2rtf
Debian:14
before 1.9.16
1.9.16

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBLaTeX2rtf 1.9.15 - Remote Buffer Overflow2004-09-21
PoC in GitHubuzzzval/cve-2004-21672018-12-05

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-2167 is a high vulnerability (CVSS 7.5) in Latex2rtf, published December 31, 2004. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 14.3%, the 96th percentile. Fixed in latex2rtf 1.9.16.

References

MoveEnter Open