CVE-2004-2215
RXVT-Unicode 3.4 and 3.5 does not properly close file descriptors, which allows local users to...
RXVT-Unicode 3.4 and 3.5 does not properly close file descriptors, which allows local users to access the terminals of other users and possibly gain privileges.
Exploit likelihood
What each source reports
NVD Score used
4.6
RXVT-Unicode 3.4 and 3.5 does not properly close file descriptors, which allows local users to access the terminals of other users and possibly gain privileges.
- Record
CVE-2004-2215- CVSS 2.0
- 4.6 Medium
AV:L/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
RXVT-Unicode 3.4 and 3.5 does not properly close file descriptors, which allows local users to access the terminals of other users and possibly gain privileges.
- Record
CVE-2004-2215- Updated
- 2026-11-02
EUVDEUVD-2004-2207 No score
RXVT-Unicode 3.4 and 3.5 does not properly close file descriptors, which allows local users to access the terminals of other users and possibly gain privileges.
- Record
EUVD-2004-2207- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-h338-p5fc-8vgw No score
RXVT-Unicode 3.4 and 3.5 does not properly close file descriptors, which allows local users to...
RXVT-Unicode 3.4 and 3.5 does not properly close file descriptors, which allows local users to access the terminals of other users and possibly gain privileges.
- Record
GHSA-h338-p5fc-8vgw- Updated
- 2026-11-02
OSV No score
RXVT-Unicode 3.4 and 3.5 does not properly close file descriptors, which allows local users to access the terminals of other users and possibly gain privileges.
- Record
CVE-2004-2215- Updated
- 2026-11-02
OSVDEBIAN-CVE-2004-2215 No score
RXVT-Unicode 3.4 and 3.5 does not properly close file descriptors, which allows local users to access the terminals of other users and possibly gain privileges.
- Record
DEBIAN-CVE-2004-2215- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
rxvt-unicodeDebian:12 |
before 3.8-1 | 3.8-1 |
rxvt-unicodeDebian:13 |
before 3.8-1 | 3.8-1 |
rxvt-unicodeDebian:14 |
before 3.8-1 | 3.8-1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2004-2215 is a medium vulnerability (CVSS 4.6) in Marc Lehmann Rxvt-unicode, published December 31, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.34%, the 27th percentile. Fixed in rxvt-unicode 3.8-1.
References
securityfocus.com/bid/10959
exchange.xforce.ibmcloud.com/vulnerabilities/17000
cvs.schmorp.de/browse/rxvt-unicode/Changes?view=markup
secunia.com/advisories/12299
osvdb.org/8710
nvd.nist.gov/vuln/detail/CVE-2004-2215
github.com/advisories/GHSA-h338-p5fc-8vgw
security-tracker.debian.org/tracker/CVE-2004-2215