Every CVE Search/ Get API key

CVE-2004-2387

Buffer overflow in the HandleCPCCommand function of sercd before 2.3.1 and sredird 2.2.1 and...

7.5 HighFix available

Buffer overflow in the HandleCPCCommand function of sercd before 2.3.1 and sredird 2.2.1 and earlier allows remote attackers to execute arbitrary code.

Exploit likelihood

3.69%Down 4.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Buffer overflow in the HandleCPCCommand function of sercd before 2.3.1 and sredird 2.2.1 and earlier allows remote attackers to execute arbitrary code.

Record
CVE-2004-2387
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Buffer overflow in the HandleCPCCommand function of sercd before 2.3.1 and sredird 2.2.1 and earlier allows remote attackers to execute arbitrary code.

Record
CVE-2004-2387
Updated
2026-11-02
EUVDEUVD-2004-2378 No score

Buffer overflow in the HandleCPCCommand function of sercd before 2.3.1 and sredird 2.2.1 and earlier allows remote attackers to execute arbitrary code.

Record
EUVD-2004-2378
Updated
2026-11-03
GitHub AdvisoriesGHSA-92cx-gx9p-3q48 No score

Buffer overflow in the HandleCPCCommand function of sercd before 2.3.1 and sredird 2.2.1 and...

Buffer overflow in the HandleCPCCommand function of sercd before 2.3.1 and sredird 2.2.1 and earlier allows remote attackers to execute arbitrary code.

Record
GHSA-92cx-gx9p-3q48
Updated
2026-11-02
OSV No score

Buffer overflow in the HandleCPCCommand function of sercd before 2.3.1 and sredird 2.2.1 and earlier allows remote attackers to execute arbitrary code.

Record
CVE-2004-2387
Updated
2026-11-02
OSVDEBIAN-CVE-2004-2387 No score

Buffer overflow in the HandleCPCCommand function of sercd before 2.3.1 and sredird 2.2.1 and earlier allows remote attackers to execute arbitrary code.

Record
DEBIAN-CVE-2004-2387
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sredird
Debian:12
before 2.2.1-1.1
2.2.1-1.1
sredird
Debian:13
before 2.2.1-1.1
2.2.1-1.1
sredird
Debian:14
before 2.2.1-1.1
2.2.1-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-2387 is a high vulnerability (CVSS 7.5) in Denis Sbragion Sredird, published December 31, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.69%, the 89th percentile. Fixed in sredird 2.2.1-1.1.

References

Show 4 moreShow less
MoveEnter Open