Every CVE Search/ Get API key

CVE-2005-0437

Directory traversal vulnerability in awstats.pl in AWStats 6.3 and 6.4 allows remote attackers to...

7.5 HighFix available

Directory traversal vulnerability in awstats.pl in AWStats 6.3 and 6.4 allows remote attackers to include arbitrary Perl modules via .. (dot dot) sequences in the loadplugin parameter.

Exploit likelihood

1.80%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Directory traversal vulnerability in awstats.pl in AWStats 6.3 and 6.4 allows remote attackers to include arbitrary Perl modules via .. (dot dot) sequences in the loadplugin parameter.

Record
CVE-2005-0437
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Directory traversal vulnerability in awstats.pl in AWStats 6.3 and 6.4 allows remote attackers to include arbitrary Perl modules via .. (dot dot) sequences in the loadplugin parameter.

Record
CVE-2005-0437
Updated
2026-11-02
EUVDEUVD-2005-0438 No score

Directory traversal vulnerability in awstats.pl in AWStats 6.3 and 6.4 allows remote attackers to include arbitrary Perl modules via .. (dot dot) sequences in the loadplugin parameter.

Record
EUVD-2005-0438
Updated
2026-11-03
GitHub AdvisoriesGHSA-v4pj-pfq5-2mmv No score

Directory traversal vulnerability in awstats.pl in AWStats 6.3 and 6.4 allows remote attackers to...

Directory traversal vulnerability in awstats.pl in AWStats 6.3 and 6.4 allows remote attackers to include arbitrary Perl modules via .. (dot dot) sequences in the loadplugin parameter.

Record
GHSA-v4pj-pfq5-2mmv
Updated
2026-11-02
OSV No score

Directory traversal vulnerability in awstats.pl in AWStats 6.3 and 6.4 allows remote attackers to include arbitrary Perl modules via .. (dot dot) sequences in the loadplugin parameter.

Record
CVE-2005-0437
Updated
2026-11-02
OSVDEBIAN-CVE-2005-0437 No score

Directory traversal vulnerability in awstats.pl in AWStats 6.3 and 6.4 allows remote attackers to include arbitrary Perl modules via .. (dot dot) sequences in the loadplugin parameter.

Record
DEBIAN-CVE-2005-0437
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
awstats
Debian:12
before 6.3-1
6.3-1
awstats
Debian:13
before 6.3-1
6.3-1
awstats
Debian:14
before 6.3-1
6.3-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-0437 is a high vulnerability (CVSS 7.5) in Awstats, published February 15, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.80%, the 78th percentile. Fixed in awstats 6.3-1.

References

MoveEnter Open