CVE-2005-1121
Format string vulnerability in the my_xlog function in lib.c for Oops! Proxy Server 1.5.23 and...
Format string vulnerability in the my_xlog function in lib.c for Oops! Proxy Server 1.5.23 and earlier, as called by the auth functions in the passwd_mysql and passwd_pgsql modules, may allow attackers to execute arbitrary code via a URL.
Exploit likelihood
What each source reports
NVD Score used
5.0
Format string vulnerability in the my_xlog function in lib.c for Oops! Proxy Server 1.5.23 and earlier, as called by the auth functions in the passwd_mysql and passwd_pgsql modules, may allow attackers to execute arbitrary code via a URL.
- Record
CVE-2005-1121- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Updated
- 2026-11-02
CVE List No score
Format string vulnerability in the my_xlog function in lib.c for Oops! Proxy Server 1.5.23 and earlier, as called by the auth functions in the passwd_mysql and passwd_pgsql modules, may allow attackers to execute arbitrary code via a URL.
- Record
CVE-2005-1121- Updated
- 2026-11-02
EUVDEUVD-2005-1124 No score
Format string vulnerability in the my_xlog function in lib.c for Oops! Proxy Server 1.5.23 and earlier, as called by the auth functions in the passwd_mysql and passwd_pgsql modules, may allow attackers to execute arbitrary code via a URL.
- Record
EUVD-2005-1124- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-348c-hvj3-g7hp No score
Format string vulnerability in the my_xlog function in lib.c for Oops! Proxy Server 1.5.23 and...
Format string vulnerability in the my_xlog function in lib.c for Oops! Proxy Server 1.5.23 and earlier, as called by the auth functions in the passwd_mysql and passwd_pgsql modules, may allow attackers to execute arbitrary code via a URL.
- Record
GHSA-348c-hvj3-g7hp- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
oopsDebian:3.0 |
before 1.5.19.cvs.20010818-0.1woody1, plus listed versions 1.5.19.cvs.20010818-0.1 |
1.5.19.cvs.20010818-0.1woody1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2005-1121 is a medium vulnerability (CVSS 5.0) in Gentoo Linux, published April 16, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.30%, the 83rd percentile. Fixed in oops 1.5.19.cvs.20010818-0.1woody1.