Every CVE Search/ Get API key

CVE-2005-1349

Buffer overflow in Convert-UUlib (Convert::UUlib) before 1.051 allows remote attackers to execute...

7.5 HighPublic exploitFix available

Buffer overflow in Convert-UUlib (Convert::UUlib) before 1.051 allows remote attackers to execute arbitrary code via a malformed parameter to a read operation.

Exploit likelihood

12.8%Up 5.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Buffer overflow in Convert-UUlib (Convert::UUlib) before 1.051 allows remote attackers to execute arbitrary code via a malformed parameter to a read operation.

Record
CVE-2005-1349
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Buffer overflow in Convert-UUlib (Convert::UUlib) before 1.051 allows remote attackers to execute arbitrary code via a malformed parameter to a read operation.

Record
CVE-2005-1349
Updated
2026-11-02
EUVDEUVD-2005-1352 No score

Buffer overflow in Convert-UUlib (Convert::UUlib) before 1.051 allows remote attackers to execute arbitrary code via a malformed parameter to a read operation.

Record
EUVD-2005-1352
Updated
2026-11-03
GitHub AdvisoriesGHSA-4x75-6x49-vgw2 No score

Buffer overflow in Convert-UUlib (Convert::UUlib) before 1.051 allows remote attackers to execute...

Buffer overflow in Convert-UUlib (Convert::UUlib) before 1.051 allows remote attackers to execute arbitrary code via a malformed parameter to a read operation.

Record
GHSA-4x75-6x49-vgw2
Updated
2026-11-02
OSV No score

Buffer overflow in Convert-UUlib (Convert::UUlib) before 1.051 allows remote attackers to execute arbitrary code via a malformed parameter to a read operation.

Record
CVE-2005-1349
Updated
2026-11-02
OSVDEBIAN-CVE-2005-1349 No score

Buffer overflow in Convert-UUlib (Convert::UUlib) before 1.051 allows remote attackers to execute arbitrary code via a malformed parameter to a read operation.

Record
DEBIAN-CVE-2005-1349
Updated
2026-11-02
OSVopenSUSE-SU-2024:10614-1 No score

amavisd-new-2.12.1-3.2 on GA media

These are all security issues fixed in the amavisd-new-2.12.1-3.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10614-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libconvert-uulib-perl
Debian:12
before 1.0.5.1
1.0.5.1
libconvert-uulib-perl
Debian:13
before 1.0.5.1
1.0.5.1
libconvert-uulib-perl
Debian:14
before 1.0.5.1
1.0.5.1
libconvert-uulib-perl
Debian:3.0
before 0.201-2woody1, plus listed versions
0.201-2
0.201-2woody1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBConvert-UUlib 1.04/1.05 Perl Module - Remote Buffer Overflow2005-04-26

History

History
RecordedChangedSources
facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-1349 is a high vulnerability (CVSS 7.5) in Perl Convert Uulib, published April 28, 2005. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 12.8%, the 96th percentile. Fixed in libconvert-uulib-perl 1.0.5.1.

References

Show 4 moreShow less
MoveEnter Open