Every CVE Search/ Get API key

CVE-2005-1546

Buffer overflow in the PE parser in HT Editor before 0.8.0 allows remote attackers to execute...

5.1 MediumFix available

Buffer overflow in the PE parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted PE file.

Exploit likelihood

2.82%Down 1.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.1

Buffer overflow in the PE parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted PE file.

Record
CVE-2005-1546
CVSS 2.0
5.1 MediumAV:N/AC:H/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Buffer overflow in the PE parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted PE file.

Record
CVE-2005-1546
Updated
2026-11-02
EUVDEUVD-2005-1549 No score

Buffer overflow in the PE parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted PE file.

Record
EUVD-2005-1549
Updated
2026-11-03
GitHub AdvisoriesGHSA-2q6w-3v2w-2hvx No score

Buffer overflow in the PE parser in HT Editor before 0.8.0 allows remote attackers to execute...

Buffer overflow in the PE parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted PE file.

Record
GHSA-2q6w-3v2w-2hvx
Updated
2026-11-02
OSV No score

Buffer overflow in the PE parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted PE file.

Record
CVE-2005-1546
Updated
2026-11-02
OSVDEBIAN-CVE-2005-1546 No score

Buffer overflow in the PE parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted PE file.

Record
DEBIAN-CVE-2005-1546
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ht
Debian:12
before 0.8.0-3
0.8.0-3
ht
Debian:13
before 0.8.0-3
0.8.0-3
ht
Debian:14
before 0.8.0-3
0.8.0-3
ht
Debian:3.0
before 0.5.0-1woody4, plus listed versions
0.5.0-1
0.5.0-1woody4
ht
Debian:3.1
before 0.8.0-2sarge4, plus listed versions
0.8.0-2
0.8.0-2sarge4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-1546 is a medium vulnerability (CVSS 5.1) in Ht Editor Editor, published May 14, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.82%, the 86th percentile. Fixed in ht 0.8.0-3.

References

MoveEnter Open