Every CVE Search/ Get API key

CVE-2005-1796

Format string vulnerability in the curses_msg function in the Ncurses interface (ec_curses.c) for...

7.5 HighFix available

Format string vulnerability in the curses_msg function in the Ncurses interface (ec_curses.c) for Ettercap before 0.7.3 allows remote attackers to execute arbitrary code.

Exploit likelihood

5.49%Down 5.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Format string vulnerability in the curses_msg function in the Ncurses interface (ec_curses.c) for Ettercap before 0.7.3 allows remote attackers to execute arbitrary code.

Record
CVE-2005-1796
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Format string vulnerability in the curses_msg function in the Ncurses interface (ec_curses.c) for Ettercap before 0.7.3 allows remote attackers to execute arbitrary code.

Record
CVE-2005-1796
Updated
2026-11-02
EUVDEUVD-2005-1798 No score

Format string vulnerability in the curses_msg function in the Ncurses interface (ec_curses.c) for Ettercap before 0.7.3 allows remote attackers to execute arbitrary code.

Record
EUVD-2005-1798
Updated
2026-11-03
GitHub AdvisoriesGHSA-m3x5-9p57-9q98 No score

Format string vulnerability in the curses_msg function in the Ncurses interface (ec_curses.c) for...

Format string vulnerability in the curses_msg function in the Ncurses interface (ec_curses.c) for Ettercap before 0.7.3 allows remote attackers to execute arbitrary code.

Record
GHSA-m3x5-9p57-9q98
Updated
2026-11-02
OSV No score

Format string vulnerability in the curses_msg function in the Ncurses interface (ec_curses.c) for Ettercap before 0.7.3 allows remote attackers to execute arbitrary code.

Record
CVE-2005-1796
Updated
2026-11-02
OSVDEBIAN-CVE-2005-1796 No score

Format string vulnerability in the curses_msg function in the Ncurses interface (ec_curses.c) for Ettercap before 0.7.3 allows remote attackers to execute arbitrary code.

Record
DEBIAN-CVE-2005-1796
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ettercap
Debian:12
before 1:0.7.1-1.1
1:0.7.1-1.1
ettercap
Debian:13
before 1:0.7.1-1.1
1:0.7.1-1.1
ettercap
Debian:3.1
before 1:0.7.1-1sarge1, plus listed versions
1:0.7.1-1
1:0.7.1-1sarge1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-1796 is a high vulnerability (CVSS 7.5) in Ettercap, published May 31, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.49%, the 92nd percentile. Fixed in ettercap 1:0.7.1-1.1.

References

Show 6 moreShow less
MoveEnter Open