Every CVE Search/ Get API key

CVE-2005-1888

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.4.5 allows remote attackers to...

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.4.5 allows remote attackers to inject arbitrary web script via HTML attributes in page templates.

Exploit likelihood

1.21%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.4.5 allows remote attackers to inject arbitrary web script via HTML attributes in page templates.

Record
CVE-2005-1888
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.4.5 allows remote attackers to inject arbitrary web script via HTML attributes in page templates.

Record
CVE-2005-1888
Updated
2026-11-02
EUVDEUVD-2005-1890 No score

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.4.5 allows remote attackers to inject arbitrary web script via HTML attributes in page templates.

Record
EUVD-2005-1890
Updated
2026-11-03
GitHub AdvisoriesGHSA-fjxw-77h7-chv3 No score

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.4.5 allows remote attackers to...

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.4.5 allows remote attackers to inject arbitrary web script via HTML attributes in page templates.

Record
GHSA-fjxw-77h7-chv3
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.4.5 allows remote attackers to inject arbitrary web script via HTML attributes in page templates.

Record
CVE-2005-1888
Updated
2026-11-02
OSVDEBIAN-CVE-2005-1888 No score

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.4.5 allows remote attackers to inject arbitrary web script via HTML attributes in page templates.

Record
DEBIAN-CVE-2005-1888
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mediawiki
Debian:12
before 1.4.9
1.4.9
mediawiki
Debian:13
before 1.4.9
1.4.9
mediawiki
Debian:14
before 1.4.9
1.4.9

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-1888 is a medium vulnerability (CVSS 4.3) in Mediawiki, published June 6, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.21%, the 68th percentile. Fixed in mediawiki 1.4.9.

References

MoveEnter Open