Every CVE Search/ Get API key

CVE-2005-2301

PowerDNS before 2.9.18, when running with an LDAP backend, does not properly escape LDAP queries,...

5.0 MediumFix available

PowerDNS before 2.9.18, when running with an LDAP backend, does not properly escape LDAP queries, which allows remote attackers to cause a denial of service (failure to answer ldap questions) and possibly conduct an LDAP injection attack.

Exploit likelihood

3.26%Up 2.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

PowerDNS before 2.9.18, when running with an LDAP backend, does not properly escape LDAP queries, which allows remote attackers to cause a denial of service (failure to answer ldap questions) and possibly conduct an LDAP injection attack.

Record
CVE-2005-2301
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

PowerDNS before 2.9.18, when running with an LDAP backend, does not properly escape LDAP queries, which allows remote attackers to cause a denial of service (failure to answer ldap questions) and possibly conduct an LDAP injection attack.

Record
CVE-2005-2301
Updated
2026-11-02
EUVDEUVD-2005-2302 No score

PowerDNS before 2.9.18, when running with an LDAP backend, does not properly escape LDAP queries, which allows remote attackers to cause a denial of service (failure to answer ldap questions) and possibly conduct an LDAP injection attack.

Record
EUVD-2005-2302
Updated
2026-11-03
GitHub AdvisoriesGHSA-g646-w53x-pjf2 No score

PowerDNS before 2.9.18, when running with an LDAP backend, does not properly escape LDAP queries,...

PowerDNS before 2.9.18, when running with an LDAP backend, does not properly escape LDAP queries, which allows remote attackers to cause a denial of service (failure to answer ldap questions) and possibly conduct an LDAP injection attack.

Record
GHSA-g646-w53x-pjf2
Updated
2026-11-02
OSV No score

PowerDNS before 2.9.18, when running with an LDAP backend, does not properly escape LDAP queries, which allows remote attackers to cause a denial of service (failure to answer ldap questions) and possibly conduct an LDAP injection attack.

Record
CVE-2005-2301
Updated
2026-11-02
OSVDEBIAN-CVE-2005-2301 No score

PowerDNS before 2.9.18, when running with an LDAP backend, does not properly escape LDAP queries, which allows remote attackers to cause a denial of service (failure to answer ldap questions) and possibly conduct an LDAP injection attack.

Record
DEBIAN-CVE-2005-2301
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pdns
Debian:12
before 2.9.18-1
2.9.18-1
pdns
Debian:13
before 2.9.18-1
2.9.18-1
pdns
Debian:14
before 2.9.18-1
2.9.18-1
pdns
Debian:3.1
From an advisory covering 2 CVEs
before 2.9.17-13sarge1, plus listed versions
2.9.17-13
2.9.17-13sarge1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-2301 is a medium vulnerability (CVSS 5.0) in Powerdns, published July 19, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.26%, the 88th percentile. Fixed in pdns 2.9.18-1.

References

MoveEnter Open