Every CVE Search/ Get API key

CVE-2005-2370

Multiple "memory alignment errors" in libgadu, as used in ekg before 1.6rc2, Gaim before 1.5.0,...

5.0 MediumFix available

Multiple "memory alignment errors" in libgadu, as used in ekg before 1.6rc2, Gaim before 1.5.0, and other packages, allows remote attackers to cause a denial of service (bus error) on certain architectures such as SPARC via an incoming message.

Exploit likelihood

2.32%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Multiple "memory alignment errors" in libgadu, as used in ekg before 1.6rc2, Gaim before 1.5.0, and other packages, allows remote attackers to cause a denial of service (bus error) on certain architectures such as SPARC via an incoming message.

Record
CVE-2005-2370
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

Multiple "memory alignment errors" in libgadu, as used in ekg before 1.6rc2, Gaim before 1.5.0, and other packages, allows remote attackers to cause a denial of service (bus error) on certain architectures such as SPARC via an incoming message.

Record
CVE-2005-2370
Updated
2026-11-02
EUVDEUVD-2005-2371 No score

Multiple "memory alignment errors" in libgadu, as used in ekg before 1.6rc2, Gaim before 1.5.0, and other packages, allows remote attackers to cause a denial of service (bus error) on certain architectures such as SPARC via an incoming message.

Record
EUVD-2005-2371
Updated
2026-11-03
GitHub AdvisoriesGHSA-qj76-x84q-4mvg No score

Multiple "memory alignment errors" in libgadu, as used in ekg before 1.6rc2, Gaim before 1.5.0,...

Multiple "memory alignment errors" in libgadu, as used in ekg before 1.6rc2, Gaim before 1.5.0, and other packages, allows remote attackers to cause a denial of service (bus error) on certain architectures such as SPARC via an incoming message.

Record
GHSA-qj76-x84q-4mvg
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ekg
Debian:3.1
From an advisory covering 5 CVEs
before 1:1.5+20050411-7, plus listed versions
1:1.5+20050411-31:1.5+20050411-41:1.5+20050411-51:1.5+20050411-6
1:1.5+20050411-7
ekg
Debian:4.0
From an advisory covering 5 CVEs
before 1:1.7~rc2-1etch1, plus listed versions
1:1.7~rc2-1
1:1.7~rc2-1etch1
gaim
Debian:3.1
before 1:1.2.1-1.4, plus listed versions
1:1.2.1-1.11:1.2.1-1.3
1:1.2.1-1.4
centericq
Debian:3.1
From an advisory covering 3 CVEs
before 4.20.0-1sarge2, plus listed versions
4.20.0-14.20.0-1sarge1
4.20.0-1sarge2
centericq
Debian:4.0
From an advisory covering 4 CVEs
before 4.20.0-8etch1
4.20.0-8etch1
gaim
Debian:4.0
From an advisory covering 3 CVEs
before 1:1.4.0-5etch2
1:1.4.0-5etch2
kdenetwork
Red Hat:enterprise_linux:4::as
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3
kdenetwork-debuginfo
Red Hat:enterprise_linux:4::as
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3
kdenetwork-devel
Red Hat:enterprise_linux:4::as
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3
kdenetwork-nowlistening
Red Hat:enterprise_linux:4::as
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3
Show 12 moreShow less
Affected packages
PackageAffectedFixed
kdenetwork
Red Hat:enterprise_linux:4::desktop
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3
kdenetwork-debuginfo
Red Hat:enterprise_linux:4::desktop
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3
kdenetwork-devel
Red Hat:enterprise_linux:4::desktop
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3
kdenetwork-nowlistening
Red Hat:enterprise_linux:4::desktop
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3
kdenetwork
Red Hat:enterprise_linux:4::es
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3
kdenetwork-debuginfo
Red Hat:enterprise_linux:4::es
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3
kdenetwork-devel
Red Hat:enterprise_linux:4::es
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3
kdenetwork-nowlistening
Red Hat:enterprise_linux:4::es
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3
kdenetwork
Red Hat:enterprise_linux:4::ws
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3
kdenetwork-debuginfo
Red Hat:enterprise_linux:4::ws
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3
kdenetwork-devel
Red Hat:enterprise_linux:4::ws
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3
kdenetwork-nowlistening
Red Hat:enterprise_linux:4::ws
From an advisory covering 4 CVEs
before 7:3.3.1-2.3
7:3.3.1-2.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
aliases
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-2370 is a medium vulnerability (CVSS 5.0) in Ekg, published July 26, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.32%, the 83rd percentile. Fixed in gaim 1:1.2.1-1.4.

References

Show 25 moreShow less
MoveEnter Open