Every CVE Search/ Get API key

CVE-2005-2964

Stack-based buffer overflow in AbiWord before 2.2.10 allows attackers to execute arbitrary code...

7.5 HighFix available

Stack-based buffer overflow in AbiWord before 2.2.10 allows attackers to execute arbitrary code via the RTF import mechanism.

Exploit likelihood

4.59%Up 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Stack-based buffer overflow in AbiWord before 2.2.10 allows attackers to execute arbitrary code via the RTF import mechanism.

Record
CVE-2005-2964
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Stack-based buffer overflow in AbiWord before 2.2.10 allows attackers to execute arbitrary code via the RTF import mechanism.

Record
CVE-2005-2964
Updated
2026-11-02
EUVDEUVD-2005-2964 No score

Stack-based buffer overflow in AbiWord before 2.2.10 allows attackers to execute arbitrary code via the RTF import mechanism.

Record
EUVD-2005-2964
Updated
2026-11-03
GitHub AdvisoriesGHSA-xc89-vpfh-32xw No score

Stack-based buffer overflow in AbiWord before 2.2.10 allows attackers to execute arbitrary code...

Stack-based buffer overflow in AbiWord before 2.2.10 allows attackers to execute arbitrary code via the RTF import mechanism.

Record
GHSA-xc89-vpfh-32xw
Updated
2026-11-02
OSV No score

Stack-based buffer overflow in AbiWord before 2.2.10 allows attackers to execute arbitrary code via the RTF import mechanism.

Record
CVE-2005-2964
Updated
2026-11-02
OSVDEBIAN-CVE-2005-2964 No score

Stack-based buffer overflow in AbiWord before 2.2.10 allows attackers to execute arbitrary code via the RTF import mechanism.

Record
DEBIAN-CVE-2005-2964
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
abiword
Debian:12
before 2.2.10-1
2.2.10-1
abiword
Debian:13
before 2.2.10-1
2.2.10-1
abiword
Debian:3.0
before 1.0.2+cvs.2002.06.05-1woody3, plus listed versions
1.0.2+cvs.2002.06.05-1woody2
1.0.2+cvs.2002.06.05-1woody3
abiword
Debian:3.1
before 2.2.7-3sarge2, plus listed versions
2.2.7-32.2.7-3sarge1
2.2.7-3sarge2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-2964 is a high vulnerability (CVSS 7.5) in Abisource Community Abiword, published September 28, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.59%, the 91st percentile. Fixed in abiword 2.2.10-1.

References

Show 14 moreShow less
MoveEnter Open