CVE-2005-3149
Uim 0.4.x before 0.4.9.1 and 0.5.0 and earlier does not properly handle the LIBUIM_VANILLA...
Uim 0.4.x before 0.4.9.1 and 0.5.0 and earlier does not properly handle the LIBUIM_VANILLA environment variable when a suid or sgid application is linked to libuim, such as immodule for Qt, which allows local users to gain privileges.
Exploit likelihood
What each source reports
NVD Score used
4.6
Uim 0.4.x before 0.4.9.1 and 0.5.0 and earlier does not properly handle the LIBUIM_VANILLA environment variable when a suid or sgid application is linked to libuim, such as immodule for Qt, which allows local users to gain privileges.
- Record
CVE-2005-3149- CVSS 2.0
- 4.6 Medium
AV:L/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Uim 0.4.x before 0.4.9.1 and 0.5.0 and earlier does not properly handle the LIBUIM_VANILLA environment variable when a suid or sgid application is linked to libuim, such as immodule for Qt, which allows local users to gain privileges.
- Record
CVE-2005-3149- Updated
- 2026-11-02
EUVDEUVD-2005-3149 No score
Uim 0.4.x before 0.4.9.1 and 0.5.0 and earlier does not properly handle the LIBUIM_VANILLA environment variable when a suid or sgid application is linked to libuim, such as immodule for Qt, which allows local users to gain privileges.
- Record
EUVD-2005-3149- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jmr8-f36w-9vrj No score
Uim 0.4.x before 0.4.9.1 and 0.5.0 and earlier does not properly handle the LIBUIM_VANILLA...
Uim 0.4.x before 0.4.9.1 and 0.5.0 and earlier does not properly handle the LIBUIM_VANILLA environment variable when a suid or sgid application is linked to libuim, such as immodule for Qt, which allows local users to gain privileges.
- Record
GHSA-jmr8-f36w-9vrj- Updated
- 2026-11-02
OSV No score
Uim 0.4.x before 0.4.9.1 and 0.5.0 and earlier does not properly handle the LIBUIM_VANILLA environment variable when a suid or sgid application is linked to libuim, such as immodule for Qt, which allows local users to gain privileges.
- Record
CVE-2005-3149- Updated
- 2026-11-02
OSVDEBIAN-CVE-2005-3149 No score
Uim 0.4.x before 0.4.9.1 and 0.5.0 and earlier does not properly handle the LIBUIM_VANILLA environment variable when a suid or sgid application is linked to libuim, such as immodule for Qt, which allows local users to gain privileges.
- Record
DEBIAN-CVE-2005-3149- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
uimDebian:12 |
before 1:0.4.7-2 | 1:0.4.7-2 |
uimDebian:13 |
before 1:0.4.7-2 | 1:0.4.7-2 |
uimDebian:14 |
before 1:0.4.7-2 | 1:0.4.7-2 |
uimDebian:3.1 |
before 1:0.4.6final1-3sarge1, plus listed versions 1:0.4.6final1-3 |
1:0.4.6final1-3sarge1 |
uimDebian:4.0 |
before 1:0.4.7-2.0etch1 | 1:0.4.7-2.0etch1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2005-3149 is a medium vulnerability (CVSS 4.6) in Uim, published October 5, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.41%, the 35th percentile. Fixed in uim 1:0.4.7-2.
References
lists.freedesktop.org/pipermail/uim/2005-September/001347.html
securityfocus.com/bid/15007
vupen.com/english/advisories/2005/1947
lists.freedesktop.org/pipermail/uim/2005-September/001346.html
securitytracker.com/id?1015002
secunia.com/advisories/17058
Show 9 moreShow less
secunia.com/advisories/17572
vupen.com/english/advisories/2005/1946
debian.org/security/2005/dsa-895
gentoo.org/security/en/glsa/glsa-200510-03.xml
secunia.com/advisories/17043
bugs.debian.org/cgi-bin/bugreport.cgi?bug=331620
nvd.nist.gov/vuln/detail/CVE-2005-3149
github.com/advisories/GHSA-jmr8-f36w-9vrj
security-tracker.debian.org/tracker/CVE-2005-3149