Every CVE Search/ Get API key

CVE-2005-3660

Linux kernel 2.4 and 2.6 allows attackers to cause a denial of service (memory exhaustion and...

4.9 MediumFix available

Linux kernel 2.4 and 2.6 allows attackers to cause a denial of service (memory exhaustion and panic) by creating a large number of connected file descriptors or socketpairs and setting a large data transfer buffer, then preventing Linux from being able to finish the transfer by causing the process to become a zombie, or closing the file descriptor without closing an associated reference.

Exploit likelihood

0.42%Down 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.9

Linux kernel 2.4 and 2.6 allows attackers to cause a denial of service (memory exhaustion and panic) by creating a large number of connected file descriptors or socketpairs and setting a large data transfer buffer, then preventing Linux from being able to finish the transfer by causing the process to become a zombie, or closing the file descriptor without closing an associated reference.

Record
CVE-2005-3660
CVSS 2.0
4.9 MediumAV:L/AC:L/Au:N/C:N/I:N/A:C
Updated
2026-11-02
CVE List No score

Linux kernel 2.4 and 2.6 allows attackers to cause a denial of service (memory exhaustion and panic) by creating a large number of connected file descriptors or socketpairs and setting a large data transfer buffer, then preventing Linux from being able to finish the transfer by causing the process to become a zombie, or closing the file descriptor without closing an associated reference.

Record
CVE-2005-3660
Updated
2026-11-02
EUVDEUVD-2005-3657 No score

Linux kernel 2.4 and 2.6 allows attackers to cause a denial of service (memory exhaustion and panic) by creating a large number of connected file descriptors or socketpairs and setting a large data transfer buffer, then preventing Linux from being able to finish the transfer by causing the process to become a zombie, or closing the file descriptor without closing an associated reference.

Record
EUVD-2005-3657
Updated
2026-11-03
GitHub AdvisoriesGHSA-3vmj-v4wc-vqf5 No score

Linux kernel 2.4 and 2.6 allows attackers to cause a denial of service (memory exhaustion and...

Linux kernel 2.4 and 2.6 allows attackers to cause a denial of service (memory exhaustion and panic) by creating a large number of connected file descriptors or socketpairs and setting a large data transfer buffer, then preventing Linux from being able to finish the transfer by causing the process to become a zombie, or closing the file descriptor without closing an associated reference.

Record
GHSA-3vmj-v4wc-vqf5
Updated
2026-11-02
OSV No score

Linux kernel 2.4 and 2.6 allows attackers to cause a denial of service (memory exhaustion and panic) by creating a large number of connected file descriptors or socketpairs and setting a large data transfer buffer, then preventing Linux from being able to finish the transfer by causing the process to become a zombie, or closing the file descriptor without closing an associated reference.

Record
CVE-2005-3660
Updated
2026-11-02
OSVDEBIAN-CVE-2005-3660 No score

Linux kernel 2.4 and 2.6 allows attackers to cause a denial of service (memory exhaustion and panic) by creating a large number of connected file descriptors or socketpairs and setting a large data transfer buffer, then preventing Linux from being able to finish the transfer by causing the process to become a zombie, or closing the file descriptor without closing an associated reference.

Record
DEBIAN-CVE-2005-3660
Updated
2026-11-02
OSVROOT-OS-DEBIAN-12-CVE-2005-3660 No score

CVE-2005-3660 in linux - Patched by Root

Root has patched CVE-2005-3660 in the linux package for Root:Debian:12. Multiple fixed versions available.

Record
ROOT-OS-DEBIAN-12-CVE-2005-3660
Updated
2026-11-02
OSVROOT-OS-DEBIAN-13-CVE-2005-3660 No score

CVE-2005-3660 in linux - Patched by Root

Root has patched CVE-2005-3660 in the linux package for Root:Debian:13. Multiple fixed versions available.

Record
ROOT-OS-DEBIAN-13-CVE-2005-3660
Updated
2026-11-03

Affected products

Affected packages

Affected packages
PackageAffectedFixed
linux
Debian:12
All versions, plus listed versions
6.1.106-16.1.106-26.1.106-36.1.112-16.1.115-1
Show 45 moreShow less
6.1.119-16.1.123-16.1.124-16.1.128-16.1.129-16.1.133-16.1.135-16.1.137-16.1.139-16.1.140-16.1.147-16.1.148-16.1.153-16.1.158-16.1.159-16.1.162-16.1.164-16.1.170-16.1.170-26.1.170-36.1.172-16.1.174-16.1.176-16.1.177-16.1.180-16.1.187-16.1.190-16.1.27-16.1.37-16.1.38-16.1.38-26.1.38-2~bpo11+16.1.38-36.1.38-46.1.38-4~bpo11+16.1.52-16.1.55-16.1.55-1~bpo11+16.1.64-16.1.66-16.1.67-16.1.69-16.1.69-1~bpo11+16.1.76-16.1.76-1~bpo11+1
None known
linux
Debian:13
All versions, plus listed versions
6.12.100-16.12.101-16.12.105-16.12.107-16.12.111-1
Show 45 moreShow less
6.12.113-16.12.38-16.12.41-16.12.43-16.12.43-1~bpo12+16.12.48-16.12.57-16.12.57-1~bpo12+16.12.63-16.12.63-1~bpo12+16.12.69-16.12.69-1~bpo12+16.12.73-16.12.73-1~bpo12+16.12.74-16.12.74-26.12.74-2~bpo12+16.12.85-16.12.85-1~bpo12+16.12.86-16.12.86-1~bpo12+16.12.88-16.12.88-1~bpo12+16.12.90-16.12.90-1~bpo12+16.12.90-26.12.90-2~bpo12+16.12.94-16.12.94-1~bpo12+16.12.95-16.12.95-1~bpo12+16.12.96-16.13.10-1~exp16.13.11-1~exp16.13.2-1~exp16.13.3-1~exp16.13.4-1~exp16.13.5-1~exp16.13.6-1~exp16.13.7-1~exp16.13.8-1~exp16.13.9-1~exp16.13~rc6-1~exp16.13~rc7-1~exp16.14.3-1~exp1
None known
linux
Debian:14
All versions, plus listed versions
6.12.100-16.12.101-16.12.105-16.12.107-16.12.111-1
Show 45 moreShow less
6.12.113-16.12.38-16.12.41-16.12.43-16.12.43-1~bpo12+16.12.48-16.12.57-16.12.57-1~bpo12+16.12.63-16.12.63-1~bpo12+16.12.69-16.12.69-1~bpo12+16.12.73-16.12.73-1~bpo12+16.12.74-16.12.74-26.12.74-2~bpo12+16.12.85-16.12.85-1~bpo12+16.12.86-16.12.86-1~bpo12+16.12.88-16.12.88-1~bpo12+16.12.90-16.12.90-1~bpo12+16.12.90-26.12.90-2~bpo12+16.12.94-16.12.94-1~bpo12+16.12.95-16.12.95-1~bpo12+16.12.96-16.13.10-1~exp16.13.11-1~exp16.13.2-1~exp16.13.3-1~exp16.13.4-1~exp16.13.5-1~exp16.13.6-1~exp16.13.7-1~exp16.13.8-1~exp16.13.9-1~exp16.13~rc6-1~exp16.13~rc7-1~exp16.14.3-1~exp1
None known
linux
Root:Debian:12
before 6.1.190-1.aikido.167
6.1.190-1.aikido.167
rootio-linux
Root:Debian:12
before 6.1.190-1.aikido.167
6.1.190-1.aikido.167
linux
Root:Debian:13
before 6.12.115-2.aikido.164
6.12.115-2.aikido.164
rootio-linux
Root:Debian:13
before 6.12.115-2.aikido.164
6.12.115-2.aikido.164

History

History
RecordedChangedSources
affectedOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-3660 is a medium vulnerability (CVSS 4.9) in Linux Kernel, published December 22, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.42%, the 36th percentile. Fixed in linux 6.1.190-1.aikido.167.

References

Show 4 moreShow less
This page doesn't list everything

Left out here: 598 versions. The JSON record has them.

MoveEnter Open