Every CVE Search/ Get API key

CVE-2005-3974

Drupal 4.5.0 through 4.5.5 and 4.6.0 through 4.6.3, when running on PHP5, does not correctly...

6.4 MediumFix available

Drupal 4.5.0 through 4.5.5 and 4.6.0 through 4.6.3, when running on PHP5, does not correctly enforce user privileges, which allows remote attackers to bypass the "access user profiles" permission.

Exploit likelihood

1.69%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.4

Drupal 4.5.0 through 4.5.5 and 4.6.0 through 4.6.3, when running on PHP5, does not correctly enforce user privileges, which allows remote attackers to bypass the "access user profiles" permission.

Record
CVE-2005-3974
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:P/I:P/A:N
Updated
2026-11-02
CVE List No score

Drupal 4.5.0 through 4.5.5 and 4.6.0 through 4.6.3, when running on PHP5, does not correctly enforce user privileges, which allows remote attackers to bypass the "access user profiles" permission.

Record
CVE-2005-3974
Updated
2026-11-02
EUVDEUVD-2005-3969 No score

Drupal 4.5.0 through 4.5.5 and 4.6.0 through 4.6.3, when running on PHP5, does not correctly enforce user privileges, which allows remote attackers to bypass the "access user profiles" permission.

Record
EUVD-2005-3969
Updated
2026-11-03
GitHub AdvisoriesGHSA-x3xc-9hqw-jqwj No score

Drupal 4.5.0 through 4.5.5 and 4.6.0 through 4.6.3, when running on PHP5, does not correctly...

Drupal 4.5.0 through 4.5.5 and 4.6.0 through 4.6.3, when running on PHP5, does not correctly enforce user privileges, which allows remote attackers to bypass the "access user profiles" permission.

Record
GHSA-x3xc-9hqw-jqwj
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal
Debian:3.1
before 4.5.3-5, plus listed versions
4.5.3-24.5.3-34.5.3-4
4.5.3-5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-3974 is a medium vulnerability (CVSS 6.4) in Drupal, published December 3, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.69%, the 77th percentile. Fixed in drupal 4.5.3-5.

References

Show 4 moreShow less
MoveEnter Open