Every CVE Search/ Get API key

CVE-2005-4592

Heap-based buffer overflow in bogofilter and bogolexer 0.96.2 allows remote attackers to cause a...

7.5 HighFix available

Heap-based buffer overflow in bogofilter and bogolexer 0.96.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via words that are longer than the input buffer used by flex.

Exploit likelihood

4.64%Down 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Heap-based buffer overflow in bogofilter and bogolexer 0.96.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via words that are longer than the input buffer used by flex.

Record
CVE-2005-4592
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in bogofilter and bogolexer 0.96.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via words that are longer than the input buffer used by flex.

Record
CVE-2005-4592
Updated
2026-11-02
EUVDEUVD-2005-4587 No score

Heap-based buffer overflow in bogofilter and bogolexer 0.96.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via words that are longer than the input buffer used by flex.

Record
EUVD-2005-4587
Updated
2026-11-03
GitHub AdvisoriesGHSA-h4rr-q2q4-72r9 No score

Heap-based buffer overflow in bogofilter and bogolexer 0.96.2 allows remote attackers to cause a...

Heap-based buffer overflow in bogofilter and bogolexer 0.96.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via words that are longer than the input buffer used by flex.

Record
GHSA-h4rr-q2q4-72r9
Updated
2026-11-02
OSV No score

Heap-based buffer overflow in bogofilter and bogolexer 0.96.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via words that are longer than the input buffer used by flex.

Record
CVE-2005-4592
Updated
2026-11-02
OSVDEBIAN-CVE-2005-4592 No score

Heap-based buffer overflow in bogofilter and bogolexer 0.96.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via words that are longer than the input buffer used by flex.

Record
DEBIAN-CVE-2005-4592
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
bogofilter
Debian:12
before 0.96.3
0.96.3
bogofilter
Debian:13
before 0.96.3
0.96.3
bogofilter
Debian:14
before 0.96.3
0.96.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-4592 is a high vulnerability (CVSS 7.5) in Bogofilter Email Filter, published December 31, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.64%, the 91st percentile. Fixed in bogofilter 0.96.3.

References

Show 4 moreShow less
MoveEnter Open