Every CVE Search/ Get API key

CVE-2006-0150

Multiple format string vulnerabilities in the auth_ldap_log_reason function in Apache auth_ldap 1...

7.5 HighFix available

Multiple format string vulnerabilities in the auth_ldap_log_reason function in Apache auth_ldap 1.6.0 and earlier allows remote attackers to execute arbitrary code via various vectors, including the username.

Exploit likelihood

5.43%Down 6.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Multiple format string vulnerabilities in the auth_ldap_log_reason function in Apache auth_ldap 1.6.0 and earlier allows remote attackers to execute arbitrary code via various vectors, including the username.

Record
CVE-2006-0150
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-134
Updated
2026-11-02
CVE List No score

Multiple format string vulnerabilities in the auth_ldap_log_reason function in Apache auth_ldap 1.6.0 and earlier allows remote attackers to execute arbitrary code via various vectors, including the username.

Record
CVE-2006-0150
Updated
2026-11-02
EUVDEUVD-2006-0158 No score

Multiple format string vulnerabilities in the auth_ldap_log_reason function in Apache auth_ldap 1.6.0 and earlier allows remote attackers to execute arbitrary code via various vectors, including the username.

Record
EUVD-2006-0158
Updated
2026-11-03
GitHub AdvisoriesGHSA-9gq6-2mjq-v47h No score

Multiple format string vulnerabilities in the auth_ldap_log_reason function in Apache auth_ldap 1...

Multiple format string vulnerabilities in the auth_ldap_log_reason function in Apache auth_ldap 1.6.0 and earlier allows remote attackers to execute arbitrary code via various vectors, including the username.

Record
GHSA-9gq6-2mjq-v47h
Weakness
CWE-134
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libapache-auth-ldap
Debian:3.0
before 1.6.0-3.1, plus listed versions
1.6.0-3
1.6.0-3.1
libapache-auth-ldap
Debian:3.1
before 1.6.0-8.1, plus listed versions
1.6.0-8
1.6.0-8.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-0150 is a high vulnerability (CVSS 7.5) in Dave Carrigan Auth Ldap, published January 9, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.43%, the 92nd percentile. Fixed in libapache-auth-ldap 1.6.0-3.1.

References

Show 10 moreShow less
MoveEnter Open