Every CVE Search/ Get API key

CVE-2006-0151

sudo 1.6.8 and other versions does not clear the PYTHONINSPECT environment variable, which allows...

7.2 HighFix available

sudo 1.6.8 and other versions does not clear the PYTHONINSPECT environment variable, which allows limited local users to gain privileges via a Python script, a variant of CVE-2005-4158.

Exploit likelihood

0.61%Down 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.2

sudo 1.6.8 and other versions does not clear the PYTHONINSPECT environment variable, which allows limited local users to gain privileges via a Python script, a variant of CVE-2005-4158.

Record
CVE-2006-0151
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

sudo 1.6.8 and other versions does not clear the PYTHONINSPECT environment variable, which allows limited local users to gain privileges via a Python script, a variant of CVE-2005-4158.

Record
CVE-2006-0151
Updated
2026-11-02
EUVDEUVD-2006-0159 No score

sudo 1.6.8 and other versions does not clear the PYTHONINSPECT environment variable, which allows limited local users to gain privileges via a Python script, a variant of CVE-2005-4158.

Record
EUVD-2006-0159
Updated
2026-11-03
GitHub AdvisoriesGHSA-7vx7-4r5w-mwxw No score

sudo 1.6.8 and other versions does not clear the PYTHONINSPECT environment variable, which allows...

sudo 1.6.8 and other versions does not clear the PYTHONINSPECT environment variable, which allows limited local users to gain privileges via a Python script, a variant of CVE-2005-4158.

Record
GHSA-7vx7-4r5w-mwxw
Updated
2026-11-02
OSV No score

sudo 1.6.8 and other versions does not clear the PYTHONINSPECT environment variable, which allows limited local users to gain privileges via a Python script, a variant of CVE-2005-4158.

Record
CVE-2006-0151
Updated
2026-11-02
OSVDEBIAN-CVE-2006-0151 No score

sudo 1.6.8 and other versions does not clear the PYTHONINSPECT environment variable, which allows limited local users to gain privileges via a Python script, a variant of CVE-2005-4158.

Record
DEBIAN-CVE-2006-0151
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sudo
Debian:12
before 1.6.8p12-1
1.6.8p12-1
sudo
Debian:13
before 1.6.8p12-1
1.6.8p12-1
sudo
Debian:14
before 1.6.8p12-1
1.6.8p12-1
sudo
Debian:3.0
From an advisory covering 2 CVEs
before 1.6.6-1.6, plus listed versions
1.6.6-1.31.6.6-1.3woody11.6.6-1.41.6.6-1.5
1.6.6-1.6
sudo
Debian:3.1
From an advisory covering 2 CVEs
before 1.6.8p7-1.4, plus listed versions
1.6.8p7-1.11.6.8p7-1.1sarge11.6.8p7-1.21.6.8p7-1.3
1.6.8p7-1.4

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-0151 is a high vulnerability (CVSS 7.2) in Todd Miller Sudo, published January 9, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.61%, the 49th percentile. Fixed in sudo 1.6.8p12-1.

References

Show 11 moreShow less
MoveEnter Open