Every CVE Search/ Get API key

CVE-2006-1354

Unspecified vulnerability in FreeRADIUS 1.0.0 up to 1.1.0 allows remote attackers to bypass...

7.5 HighFix available

Unspecified vulnerability in FreeRADIUS 1.0.0 up to 1.1.0 allows remote attackers to bypass authentication or cause a denial of service (server crash) via "Insufficient input validation" in the EAP-MSCHAPv2 state machine module.

Exploit likelihood

2.83%Down 1.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Unspecified vulnerability in FreeRADIUS 1.0.0 up to 1.1.0 allows remote attackers to bypass authentication or cause a denial of service (server crash) via "Insufficient input validation" in the EAP-MSCHAPv2 state machine module.

Record
CVE-2006-1354
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Unspecified vulnerability in FreeRADIUS 1.0.0 up to 1.1.0 allows remote attackers to bypass authentication or cause a denial of service (server crash) via "Insufficient input validation" in the EAP-MSCHAPv2 state machine module.

Record
CVE-2006-1354
Updated
2026-11-02
EUVDEUVD-2006-1358 No score

Unspecified vulnerability in FreeRADIUS 1.0.0 up to 1.1.0 allows remote attackers to bypass authentication or cause a denial of service (server crash) via "Insufficient input validation" in the EAP-MSCHAPv2 state machine module.

Record
EUVD-2006-1358
Updated
2026-11-03
GitHub AdvisoriesGHSA-778m-hp9h-2cxq No score

Unspecified vulnerability in FreeRADIUS 1.0.0 up to 1.1.0 allows remote attackers to bypass...

Unspecified vulnerability in FreeRADIUS 1.0.0 up to 1.1.0 allows remote attackers to bypass authentication or cause a denial of service (server crash) via "Insufficient input validation" in the EAP-MSCHAPv2 state machine module.

Record
GHSA-778m-hp9h-2cxq
Updated
2026-11-02
OSV No score

Unspecified vulnerability in FreeRADIUS 1.0.0 up to 1.1.0 allows remote attackers to bypass authentication or cause a denial of service (server crash) via "Insufficient input validation" in the EAP-MSCHAPv2 state machine module.

Record
CVE-2006-1354
Updated
2026-11-02
OSVDEBIAN-CVE-2006-1354 No score

Unspecified vulnerability in FreeRADIUS 1.0.0 up to 1.1.0 allows remote attackers to bypass authentication or cause a denial of service (server crash) via "Insufficient input validation" in the EAP-MSCHAPv2 state machine module.

Record
DEBIAN-CVE-2006-1354
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
freeradius
Debian:12
before 1.1.0-1.2
1.1.0-1.2
freeradius
Debian:13
before 1.1.0-1.2
1.1.0-1.2
freeradius
Debian:14
before 1.1.0-1.2
1.1.0-1.2
freeradius
Debian:3.1
From an advisory covering 2 CVEs
before 1.0.2-4sarge1, plus listed versions
1.0.2-4
1.0.2-4sarge1
freeradius
Red Hat:enterprise_linux:3::as
From an advisory covering 2 CVEs
before 0:1.0.1-2.RHEL3.2
0:1.0.1-2.RHEL3.2
freeradius-debuginfo
Red Hat:enterprise_linux:3::as
From an advisory covering 2 CVEs
before 0:1.0.1-2.RHEL3.2
0:1.0.1-2.RHEL3.2
freeradius
Red Hat:enterprise_linux:3::es
From an advisory covering 2 CVEs
before 0:1.0.1-2.RHEL3.2
0:1.0.1-2.RHEL3.2
freeradius-debuginfo
Red Hat:enterprise_linux:3::es
From an advisory covering 2 CVEs
before 0:1.0.1-2.RHEL3.2
0:1.0.1-2.RHEL3.2
freeradius
Red Hat:enterprise_linux:4::as
From an advisory covering 2 CVEs
before 0:1.0.1-3.RHEL4.3
0:1.0.1-3.RHEL4.3
freeradius-debuginfo
Red Hat:enterprise_linux:4::as
From an advisory covering 2 CVEs
before 0:1.0.1-3.RHEL4.3
0:1.0.1-3.RHEL4.3
Show 8 moreShow less
Affected packages
PackageAffectedFixed
freeradius-mysql
Red Hat:enterprise_linux:4::as
From an advisory covering 2 CVEs
before 0:1.0.1-3.RHEL4.3
0:1.0.1-3.RHEL4.3
freeradius-postgresql
Red Hat:enterprise_linux:4::as
From an advisory covering 2 CVEs
before 0:1.0.1-3.RHEL4.3
0:1.0.1-3.RHEL4.3
freeradius-unixODBC
Red Hat:enterprise_linux:4::as
From an advisory covering 2 CVEs
before 0:1.0.1-3.RHEL4.3
0:1.0.1-3.RHEL4.3
freeradius
Red Hat:enterprise_linux:4::es
From an advisory covering 2 CVEs
before 0:1.0.1-3.RHEL4.3
0:1.0.1-3.RHEL4.3
freeradius-debuginfo
Red Hat:enterprise_linux:4::es
From an advisory covering 2 CVEs
before 0:1.0.1-3.RHEL4.3
0:1.0.1-3.RHEL4.3
freeradius-mysql
Red Hat:enterprise_linux:4::es
From an advisory covering 2 CVEs
before 0:1.0.1-3.RHEL4.3
0:1.0.1-3.RHEL4.3
freeradius-postgresql
Red Hat:enterprise_linux:4::es
From an advisory covering 2 CVEs
before 0:1.0.1-3.RHEL4.3
0:1.0.1-3.RHEL4.3
freeradius-unixODBC
Red Hat:enterprise_linux:4::es
From an advisory covering 2 CVEs
before 0:1.0.1-3.RHEL4.3
0:1.0.1-3.RHEL4.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-1354 is a high vulnerability (CVSS 7.5) in Freeradius, published March 22, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.83%, the 86th percentile. Fixed in freeradius 1.1.0-1.2.

References

Show 27 moreShow less
MoveEnter Open