Every CVE Search/ Get API key

CVE-2006-1629

OpenVPN 2.0 through 2.0.5 allows remote malicious servers to execute arbitrary code on the client...

9.0 HighFix available

OpenVPN 2.0 through 2.0.5 allows remote malicious servers to execute arbitrary code on the client by using setenv with the LD_PRELOAD environment variable.

Exploit likelihood

3.09%Down 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.0

OpenVPN 2.0 through 2.0.5 allows remote malicious servers to execute arbitrary code on the client by using setenv with the LD_PRELOAD environment variable.

Record
CVE-2006-1629
CVSS 2.0
9.0 HighAV:N/AC:L/Au:S/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

OpenVPN 2.0 through 2.0.5 allows remote malicious servers to execute arbitrary code on the client by using setenv with the LD_PRELOAD environment variable.

Record
CVE-2006-1629
Updated
2026-11-02
EUVDEUVD-2006-1630 No score

OpenVPN 2.0 through 2.0.5 allows remote malicious servers to execute arbitrary code on the client by using setenv with the LD_PRELOAD environment variable.

Record
EUVD-2006-1630
Updated
2026-11-03
GitHub AdvisoriesGHSA-8fqr-f734-rf7m No score

OpenVPN 2.0 through 2.0.5 allows remote malicious servers to execute arbitrary code on the client...

OpenVPN 2.0 through 2.0.5 allows remote malicious servers to execute arbitrary code on the client by using setenv with the LD_PRELOAD environment variable.

Record
GHSA-8fqr-f734-rf7m
Updated
2026-11-02
OSV No score

OpenVPN 2.0 through 2.0.5 allows remote malicious servers to execute arbitrary code on the client by using setenv with the LD_PRELOAD environment variable.

Record
CVE-2006-1629
Updated
2026-11-02
OSVDEBIAN-CVE-2006-1629 No score

OpenVPN 2.0 through 2.0.5 allows remote malicious servers to execute arbitrary code on the client by using setenv with the LD_PRELOAD environment variable.

Record
DEBIAN-CVE-2006-1629
Updated
2026-11-02
OSVopenSUSE-SU-2024:11128-1 No score

openvpn-2.5.3-1.2 on GA media

These are all security issues fixed in the openvpn-2.5.3-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11128-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openvpn
Debian:12
before 2.0.6-1
2.0.6-1
openvpn
Debian:13
before 2.0.6-1
2.0.6-1
openvpn
Debian:14
before 2.0.6-1
2.0.6-1
openvpn
Debian:3.1
before 2.0-1sarge3, plus listed versions
2.0-12.0-1sarge12.0-1sarge2
2.0-1sarge3
openvpn
openSUSE:Tumbleweed
From an advisory covering 10 CVEs
before 2.5.3-1.2
2.5.3-1.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-1629 is a high vulnerability (CVSS 9.0) in Openvpn, published April 6, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.09%, the 87th percentile. Fixed in openvpn 2.0.6-1.

References

Show 21 moreShow less
MoveEnter Open