CVE-2006-2148
Multiple buffer overflows in client.c in CGI:IRC (CGIIRC) before 0.5.8 might allow remote...
CVE-2006-2148 is a high vulnerability (CVSS 7.5) in Cgiirc, published May 2, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.73%, the 91st percentile. Fixed in cgiirc 0.5.4-6sarge1.
Multiple buffer overflows in client.c in CGI:IRC (CGIIRC) before 0.5.8 might allow remote attackers to execute arbitrary code via (1) cookies or (2) the query string.
Exploit likelihood
What each source reports
NVD Score used
7.5
Multiple buffer overflows in client.c in CGI:IRC (CGIIRC) before 0.5.8 might allow remote attackers to execute arbitrary code via (1) cookies or (2) the query string.
- Record
CVE-2006-2148- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Multiple buffer overflows in client.c in CGI:IRC (CGIIRC) before 0.5.8 might allow remote attackers to execute arbitrary code via (1) cookies or (2) the query string.
- Record
CVE-2006-2148- Updated
- 2026-11-02
EUVDEUVD-2006-2149 No score
Multiple buffer overflows in client.c in CGI:IRC (CGIIRC) before 0.5.8 might allow remote attackers to execute arbitrary code via (1) cookies or (2) the query string.
- Record
EUVD-2006-2149- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4p74-p8mw-x844 No score
Multiple buffer overflows in client.c in CGI:IRC (CGIIRC) before 0.5.8 might allow remote...
Multiple buffer overflows in client.c in CGI:IRC (CGIIRC) before 0.5.8 might allow remote attackers to execute arbitrary code via (1) cookies or (2) the query string.
- Record
GHSA-4p74-p8mw-x844- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cgiircDebian:3.1 |
before 0.5.4-6sarge1, plus listed versions 0.5.4-6 |
0.5.4-6sarge1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |