Every CVE Search/ Get API key

CVE-2006-2223

RIPd in Quagga 0.98 and 0.99 before 20060503 does not properly implement configurations that (1)...

5.0 MediumPublic exploit

RIPd in Quagga 0.98 and 0.99 before 20060503 does not properly implement configurations that (1) disable RIPv1 or (2) require plaintext or MD5 authentication, which allows remote attackers to obtain sensitive information (routing state) via REQUEST packets such as SEND UPDATE.

Exploit likelihood

11.5%Down 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

RIPd in Quagga 0.98 and 0.99 before 20060503 does not properly implement configurations that (1) disable RIPv1 or (2) require plaintext or MD5 authentication, which allows remote attackers to obtain sensitive information (routing state) via REQUEST packets such as SEND UPDATE.

Record
CVE-2006-2223
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

RIPd in Quagga 0.98 and 0.99 before 20060503 does not properly implement configurations that (1) disable RIPv1 or (2) require plaintext or MD5 authentication, which allows remote attackers to obtain sensitive information (routing state) via REQUEST packets such as SEND UPDATE.

Record
CVE-2006-2223
Updated
2026-11-02
EUVDEUVD-2006-2224 No score

RIPd in Quagga 0.98 and 0.99 before 20060503 does not properly implement configurations that (1) disable RIPv1 or (2) require plaintext or MD5 authentication, which allows remote attackers to obtain sensitive information (routing state) via REQUEST packets such as SEND UPDATE.

Record
EUVD-2006-2224
Updated
2026-11-03
GitHub AdvisoriesGHSA-xx8x-qm77-m9x3 No score

RIPd in Quagga 0.98 and 0.99 before 20060503 does not properly implement configurations that (1)...

RIPd in Quagga 0.98 and 0.99 before 20060503 does not properly implement configurations that (1) disable RIPv1 or (2) require plaintext or MD5 authentication, which allows remote attackers to obtain sensitive information (routing state) via REQUEST packets such as SEND UPDATE.

Record
GHSA-xx8x-qm77-m9x3
Weakness
CWE-20
Updated
2026-11-02
OSV No score

RIPd in Quagga 0.98 and 0.99 before 20060503 does not properly implement configurations that (1) disable RIPv1 or (2) require plaintext or MD5 authentication, which allows remote attackers to obtain sensitive information (routing state) via REQUEST packets such as SEND UPDATE.

Record
CVE-2006-2223
Updated
2026-11-02
OSVopenSUSE-SU-2024:11290-1 No score

libfpm_pb0-1.2.4-2.14 on GA media

These are all security issues fixed in the libfpm_pb0-1.2.4-2.14 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11290-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
quagga
Debian:3.1
From an advisory covering 3 CVEs
before 0.98.3-7.2, plus listed versions
0.98.3-70.98.3-7.1
0.98.3-7.2
quagga
Red Hat:enterprise_linux:3::as
From an advisory covering 3 CVEs
before 0:0.96.2-11.3E
0:0.96.2-11.3E
quagga-debuginfo
Red Hat:enterprise_linux:3::as
From an advisory covering 3 CVEs
before 0:0.96.2-11.3E
0:0.96.2-11.3E
quagga
Red Hat:enterprise_linux:3::es
From an advisory covering 3 CVEs
before 0:0.96.2-11.3E
0:0.96.2-11.3E
quagga-debuginfo
Red Hat:enterprise_linux:3::es
From an advisory covering 3 CVEs
before 0:0.96.2-11.3E
0:0.96.2-11.3E
quagga
Red Hat:enterprise_linux:4::as
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
quagga-contrib
Red Hat:enterprise_linux:4::as
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
quagga-debuginfo
Red Hat:enterprise_linux:4::as
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
quagga-devel
Red Hat:enterprise_linux:4::as
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
quagga
Red Hat:enterprise_linux:4::desktop
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
Show 12 moreShow less
Affected packages
PackageAffectedFixed
quagga-contrib
Red Hat:enterprise_linux:4::desktop
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
quagga-debuginfo
Red Hat:enterprise_linux:4::desktop
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
quagga-devel
Red Hat:enterprise_linux:4::desktop
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
quagga
Red Hat:enterprise_linux:4::es
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
quagga-contrib
Red Hat:enterprise_linux:4::es
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
quagga-debuginfo
Red Hat:enterprise_linux:4::es
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
quagga-devel
Red Hat:enterprise_linux:4::es
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
quagga
Red Hat:enterprise_linux:4::ws
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
quagga-contrib
Red Hat:enterprise_linux:4::ws
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
quagga-debuginfo
Red Hat:enterprise_linux:4::ws
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
quagga-devel
Red Hat:enterprise_linux:4::ws
From an advisory covering 3 CVEs
before 0:0.98.3-2.4E
0:0.98.3-2.4E
quagga
openSUSE:Tumbleweed
From an advisory covering 12 CVEs
before 1.2.4-2.14
1.2.4-2.14

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-2223 is a medium vulnerability (CVSS 5.0) in Quagga, published May 5, 2006. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 11.5%, the 96th percentile. No source names a fixed version.

References

Show 47 moreShow less
MoveEnter Open