Every CVE Search/ Get API key

CVE-2006-2743

Drupal 4.6.x before 4.6.7 and 4.7.0, when running on Apache with mod_mime, does not properly...

5.1 MediumPublic exploitFix available

CVE-2006-2743 is a medium vulnerability (CVSS 5.1) in Drupal, published June 1, 2006. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 11.1%, the 95th percentile. Fixed in drupal 4.5.3-6.1sarge1.

Drupal 4.6.x before 4.6.7 and 4.7.0, when running on Apache with mod_mime, does not properly handle files with multiple extensions, which allows remote attackers to upload, modify, or execute arbitrary files in the files directory.

Exploit likelihood

11.1%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.1

Drupal 4.6.x before 4.6.7 and 4.7.0, when running on Apache with mod_mime, does not properly handle files with multiple extensions, which allows remote attackers to upload, modify, or execute arbitrary files in the files directory.

Record
CVE-2006-2743
CVSS 2.0
5.1 MediumAV:N/AC:H/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Drupal 4.6.x before 4.6.7 and 4.7.0, when running on Apache with mod_mime, does not properly handle files with multiple extensions, which allows remote attackers to upload, modify, or execute arbitrary files in the files directory.

Record
CVE-2006-2743
Updated
2026-11-02
EUVDEUVD-2006-2742 No score

Drupal 4.6.x before 4.6.7 and 4.7.0, when running on Apache with mod_mime, does not properly handle files with multiple extensions, which allows remote attackers to upload, modify, or execute arbitrary files in the files directory.

Record
EUVD-2006-2742
Updated
2026-11-03
GitHub AdvisoriesGHSA-j3j6-6mpf-p2c4 No score

Drupal 4.6.x before 4.6.7 and 4.7.0, when running on Apache with mod_mime, does not properly...

Drupal 4.6.x before 4.6.7 and 4.7.0, when running on Apache with mod_mime, does not properly handle files with multiple extensions, which allows remote attackers to upload, modify, or execute arbitrary files in the files directory.

Record
GHSA-j3j6-6mpf-p2c4
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal
Debian:3.1
before 4.5.3-6.1sarge1, plus listed versions
4.5.3-24.5.3-34.5.3-44.5.3-54.5.3-6
4.5.3-6.1sarge1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBDrupal 4.7 - 'Attachment mod_mime' Remote Command Execution2006-05-24

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

References

Show 5 moreShow less
MoveEnter Open