Every CVE Search/ Get API key

CVE-2006-2802

Buffer overflow in the HTTP Plugin (xineplug_inp_http.so) for xine-lib 1.1.1 allows remote...

5.0 MediumPublic exploitFix available

Buffer overflow in the HTTP Plugin (xineplug_inp_http.so) for xine-lib 1.1.1 allows remote attackers to cause a denial of service (application crash) via a long reply from an HTTP server, as demonstrated using gxine 0.5.6.

Exploit likelihood

11.1%Down 1.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Buffer overflow in the HTTP Plugin (xineplug_inp_http.so) for xine-lib 1.1.1 allows remote attackers to cause a denial of service (application crash) via a long reply from an HTTP server, as demonstrated using gxine 0.5.6.

Record
CVE-2006-2802
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

Buffer overflow in the HTTP Plugin (xineplug_inp_http.so) for xine-lib 1.1.1 allows remote attackers to cause a denial of service (application crash) via a long reply from an HTTP server, as demonstrated using gxine 0.5.6.

Record
CVE-2006-2802
Updated
2026-11-02
EUVDEUVD-2006-2799 No score

Buffer overflow in the HTTP Plugin (xineplug_inp_http.so) for xine-lib 1.1.1 allows remote attackers to cause a denial of service (application crash) via a long reply from an HTTP server, as demonstrated using gxine 0.5.6.

Record
EUVD-2006-2799
Updated
2026-11-03
GitHub AdvisoriesGHSA-4qgc-r788-x389 No score

Buffer overflow in the HTTP Plugin (xineplug_inp_http.so) for xine-lib 1.1.1 allows remote...

Buffer overflow in the HTTP Plugin (xineplug_inp_http.so) for xine-lib 1.1.1 allows remote attackers to cause a denial of service (application crash) via a long reply from an HTTP server, as demonstrated using gxine 0.5.6.

Record
GHSA-4qgc-r788-x389
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xine-lib
Debian:3.0
before 0.9.8-2woody5, plus listed versions
0.9.8-20.9.8-2woody30.9.8-2woody4
0.9.8-2woody5
xine-lib
Debian:3.1
before 1.0.1-1sarge3, plus listed versions
1.0.1-11.0.1-1sarge11.0.1-1sarge2
1.0.1-1sarge3

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBgxine 0.5.6 - HTTP Plugin Remote Buffer Overflow (PoC)2006-05-30

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-2802 is a medium vulnerability (CVSS 5.0) in Xine Gxine, published June 3, 2006. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 11.1%, the 95th percentile. Fixed in xine-lib 0.9.8-2woody5.

References

Show 11 moreShow less
MoveEnter Open