CVE-2006-2831
Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2, when running under certain Apache...
CVE-2006-2831 is a high vulnerability (CVSS 7.5) in Drupal, published June 6, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.07%, the 90th percentile. Fixed in drupal 4.5.3-6.1sarge1.
Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2, when running under certain Apache configurations such as when FileInfo overrides are disabled within .htaccess, allows remote attackers to execute arbitrary code by uploading a file with multiple extensions, a variant of CVE-2006-2743.
Exploit likelihood
What each source reports
NVD Score used
7.5
Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2, when running under certain Apache configurations such as when FileInfo overrides are disabled within .htaccess, allows remote attackers to execute arbitrary code by uploading a file with multiple extensions, a variant of CVE-2006-2743.
- Record
CVE-2006-2831- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2, when running under certain Apache configurations such as when FileInfo overrides are disabled within .htaccess, allows remote attackers to execute arbitrary code by uploading a file with multiple extensions, a variant of CVE-2006-2743.
- Record
CVE-2006-2831- Updated
- 2026-11-02
EUVDEUVD-2006-2828 No score
Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2, when running under certain Apache configurations such as when FileInfo overrides are disabled within .htaccess, allows remote attackers to execute arbitrary code by uploading a file with multiple extensions, a variant of CVE-2006-2743.
- Record
EUVD-2006-2828- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3px9-8vx9-h7qg No score
Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2, when running under certain Apache...
Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2, when running under certain Apache configurations such as when FileInfo overrides are disabled within .htaccess, allows remote attackers to execute arbitrary code by uploading a file with multiple extensions, a variant of CVE-2006-2743.
- Record
GHSA-3px9-8vx9-h7qg- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
drupalDebian:3.1 |
before 4.5.3-6.1sarge1, plus listed versions 4.5.3-24.5.3-34.5.3-44.5.3-54.5.3-6 |
4.5.3-6.1sarge1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
securityfocus.com/bid/18245
securityfocus.com/archive/1/435792/100/0/threaded
debian.org/security/2006/dsa-1125
secunia.com/advisories/21244
drupal.org/node/66763
securityreason.com/securityalert/1042
drupal.org/files/sa-2006-007/advisory.txt
nvd.nist.gov/vuln/detail/CVE-2006-2831
github.com/advisories/GHSA-3px9-8vx9-h7qg