Every CVE Search/ Get API key

CVE-2006-4339

Openssl: openssl: signature forgery via improper pkcs-1 padding removal leading to certificate validation bypass

9.1 CriticalFix available

A flaw was found in OpenSSL. When configured to use an RSA key with exponent 3, OpenSSL improperly removes PKCS-1 padding before generating a hash. This allows remote attackers to forge PKCS #1 v1.5 signatures. Consequently, OpenSSL may incorrectly verify X.509 and other certificates, leading to a bypass of trust and authentication mechanisms.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

3.95%Down 30.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

CVE List Score used 9.1

Openssl: openssl: signature forgery via improper pkcs-1 padding removal leading to certificate validation bypass

A flaw was found in OpenSSL. When configured to use an RSA key with exponent 3, OpenSSL improperly removes PKCS-1 padding before generating a hash. This allows remote attackers to forge PKCS #1 v1.5 signatures. Consequently, OpenSSL may incorrectly verify X.509 and other certificates, leading to a bypass of trust and authentication mechanisms.

Record
CVE-2006-4339
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-347
Updated
2026-11-04
EUVDEUVD-2006-4327 9.1

A flaw was found in OpenSSL. When configured to use an RSA key with exponent 3, OpenSSL improperly removes PKCS-1 padding before generating a hash. This allows remote attackers to forge PKCS #1 v1.5 signatures. Consequently, OpenSSL may incorrectly verify X.509 and other certificates, leading to a bypass of trust and authentication mechanisms.

Record
EUVD-2006-4327
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-04
GitHub AdvisoriesGHSA-cw9v-mmf8-gmmr No score

OpenSSL before 0.9.7, 0.9.7 before 0.9.7k, and 0.9.8 before 0.9.8c, when using an RSA key with...

OpenSSL before 0.9.7, 0.9.7 before 0.9.7k, and 0.9.8 before 0.9.8c, when using an RSA key with exponent 3, removes PKCS-1 padding before generating a hash, which allows remote attackers to forge a PKCS #1 v1.5 signature that is signed by that RSA key and prevents OpenSSL from correctly verifying X.509 and other certificates that use PKCS #1.

Record
GHSA-cw9v-mmf8-gmmr
Updated
2026-11-02
NVD 9.1

A flaw was found in OpenSSL. When configured to use an RSA key with exponent 3, OpenSSL improperly removes PKCS-1 padding before generating a hash. This allows remote attackers to forge PKCS #1 v1.5 signatures. Consequently, OpenSSL may incorrectly verify X.509 and other certificates, leading to a bypass of trust and authentication mechanisms.

Record
CVE-2006-4339
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:P/I:N/A:N
Weakness
CWE-347, CWE-310
Updated
2026-11-04
OSVDEBIAN-CVE-2006-4339 9.1

A flaw was found in OpenSSL. When configured to use an RSA key with exponent 3, OpenSSL improperly removes PKCS-1 padding before generating a hash. This allows remote attackers to forge PKCS #1 v1.5 signatures. Consequently, OpenSSL may incorrectly verify X.509 and other certificates, leading to a bypass of trust and authentication mechanisms.

Record
DEBIAN-CVE-2006-4339
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-05
OSV No score

OpenSSL before 0.9.7, 0.9.7 before 0.9.7k, and 0.9.8 before 0.9.8c, when using an RSA key with exponent 3, removes PKCS-1 padding before generating a hash, which allows remote attackers to forge a PKCS #1 v1.5 signature that is signed by that RSA key and prevents OpenSSL from correctly verifying X.509 and other certificates that use PKCS #1.

Record
CVE-2006-4339
Updated
2026-11-02
Show 6 moreShow less
OSVopenSUSE-SU-2024:10650-1 No score

bind-9.16.20-1.4 on GA media

These are all security issues fixed in the bind-9.16.20-1.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10650-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11125-1 No score

libopenssl-devel-1.1.1l-1.2 on GA media

These are all security issues fixed in the libopenssl-devel-1.1.1l-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11125-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11126-1 No score

libopenssl-1_0_0-devel-1.0.2u-6.2 on GA media

These are all security issues fixed in the libopenssl-1_0_0-devel-1.0.2u-6.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11126-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11127-1 No score

libopenssl-1_1-devel-1.1.1l-1.2 on GA media

These are all security issues fixed in the libopenssl-1_1-devel-1.1.1l-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11127-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11128-1 No score

openvpn-2.5.3-1.2 on GA media

These are all security issues fixed in the openvpn-2.5.3-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11128-1
Updated
2026-11-02
OSVSUSE-FU-2022:0445-1 No score

Feature update for venv-salt-minion

This feature update for venv-salt-minion provides the following changes:

  • Introduce venv-salt-minion.
  • Mention fixed issues provided with the bundle.
Record
SUSE-FU-2022:0445-1
Updated
2026-11-02

Affected products

Show 2 moreShow less

Affected packages

Affected packages
PackageAffectedFixed
openssl
Debian:12
before 0.9.8b-3
0.9.8b-3
openssl
Debian:13
before 0.9.8b-3
0.9.8b-3
openssl
Debian:14
before 0.9.8b-3
0.9.8b-3
openssl
Debian:3.1
before 0.9.7e-3sarge2, plus listed versions
0.9.7e-30.9.7e-3sarge1
0.9.7e-3sarge2
openssl096
Debian:3.1
before 0.9.6m-1sarge2, plus listed versions
0.9.6m-10.9.6m-1sarge1
0.9.6m-1sarge2
rhn-solaris-bootstrap
Red Hat:network_satellite:5.0:el4
From an advisory covering 12 CVEs
before 0:5.0.2-3
0:5.0.2-3
rhn_solaris_bootstrap_5_0_2_3
Red Hat:network_satellite:5.0:el4
From an advisory covering 12 CVEs
before 0:1-0
0:1-0
rhn-solaris-bootstrap
Red Hat:network_satellite:4.2::el3
From an advisory covering 12 CVEs
before 0:5.0.2-3
0:5.0.2-3
rhn_solaris_bootstrap_5_0_2_3
Red Hat:network_satellite:4.2::el3
From an advisory covering 12 CVEs
before 0:1-0
0:1-0
rhn-solaris-bootstrap
Red Hat:network_satellite:4.2::el4
From an advisory covering 12 CVEs
before 0:5.0.2-3
0:5.0.2-3
Show 7 moreShow less
Affected packages
PackageAffectedFixed
rhn_solaris_bootstrap_5_0_2_3
Red Hat:network_satellite:4.2::el4
From an advisory covering 12 CVEs
before 0:1-0
0:1-0
rhn-solaris-bootstrap
Red Hat:network_satellite:5.1::el4
From an advisory covering 12 CVEs
before 0:5.1.1-3
0:5.1.1-3
rhn_solaris_bootstrap_5_1_1_3
Red Hat:network_satellite:5.1::el4
From an advisory covering 12 CVEs
before 0:1-0
0:1-0
bind
openSUSE:Tumbleweed
From an advisory covering 32 CVEs
before 9.16.20-1.4
9.16.20-1.4
openssl-1_0_0
openSUSE:Tumbleweed
From an advisory covering 29 CVEs
before 1.0.2u-6.2
1.0.2u-6.2
openssl-1_1
openSUSE:Tumbleweed
From an advisory covering 136 CVEs
before 1.1.1l-1.2
1.1.1l-1.2
openvpn
openSUSE:Tumbleweed
From an advisory covering 10 CVEs
before 2.5.3-1.2
2.5.3-1.2

History

History
RecordedChangedSources
affectedCVE List, NVD, OSV
factsEUVD
affected
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-4339 is a critical vulnerability (CVSS 9.1) in Openssl, published September 5, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.95%, the 90th percentile. Fixed in openssl 0.9.8b-3.

References

Show 194 moreShow less
This page doesn't list everything

Left out here: 784 references. The JSON record has them.

MoveEnter Open