Every CVE Search/ Get API key

CVE-2006-4514

Heap-based buffer overflow in the ole_info_read_metabat function in Gnome Structured File library...

7.5 HighFix available

Heap-based buffer overflow in the ole_info_read_metabat function in Gnome Structured File library (libgsf) 1.14.0, and other versions before 1.14.2, allows context-dependent attackers to execute arbitrary code via a large num_metabat value in an OLE document, which causes the ole_init_info function to allocate insufficient memory.

Exploit likelihood

4.43%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Heap-based buffer overflow in the ole_info_read_metabat function in Gnome Structured File library (libgsf) 1.14.0, and other versions before 1.14.2, allows context-dependent attackers to execute arbitrary code via a large num_metabat value in an OLE document, which causes the ole_init_info function to allocate insufficient memory.

Record
CVE-2006-4514
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in the ole_info_read_metabat function in Gnome Structured File library (libgsf) 1.14.0, and other versions before 1.14.2, allows context-dependent attackers to execute arbitrary code via a large num_metabat value in an OLE document, which causes the ole_init_info function to allocate insufficient memory.

Record
CVE-2006-4514
Updated
2026-11-02
EUVDEUVD-2006-4502 No score

Heap-based buffer overflow in the ole_info_read_metabat function in Gnome Structured File library (libgsf) 1.14.0, and other versions before 1.14.2, allows context-dependent attackers to execute arbitrary code via a large num_metabat value in an OLE document, which causes the ole_init_info function to allocate insufficient memory.

Record
EUVD-2006-4502
Updated
2026-11-03
GitHub AdvisoriesGHSA-rp23-2xcw-7j87 No score

Heap-based buffer overflow in the ole_info_read_metabat function in Gnome Structured File library...

Heap-based buffer overflow in the ole_info_read_metabat function in Gnome Structured File library (libgsf) 1.14.0, and other versions before 1.14.2, allows context-dependent attackers to execute arbitrary code via a large num_metabat value in an OLE document, which causes the ole_init_info function to allocate insufficient memory.

Record
GHSA-rp23-2xcw-7j87
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Heap-based buffer overflow in the ole_info_read_metabat function in Gnome Structured File library (libgsf) 1.14.0, and other versions before 1.14.2, allows context-dependent attackers to execute arbitrary code via a large num_metabat value in an OLE document, which causes the ole_init_info function to allocate insufficient memory.

Record
CVE-2006-4514
Updated
2026-11-02
OSVDEBIAN-CVE-2006-4514 No score

Heap-based buffer overflow in the ole_info_read_metabat function in Gnome Structured File library (libgsf) 1.14.0, and other versions before 1.14.2, allows context-dependent attackers to execute arbitrary code via a large num_metabat value in an OLE document, which causes the ole_init_info function to allocate insufficient memory.

Record
DEBIAN-CVE-2006-4514
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libgsf
Debian:12
before 1.14.2-1
1.14.2-1
libgsf
Debian:13
before 1.14.2-1
1.14.2-1
libgsf
Debian:14
before 1.14.2-1
1.14.2-1
libgsf
Debian:3.1
before 1.11.1-1sarge1, plus listed versions
1.11.1-1
1.11.1-1sarge1
libgsf
Red Hat:enterprise_linux:3::as
before 0:1.6.0-7
0:1.6.0-7
libgsf-debuginfo
Red Hat:enterprise_linux:3::as
before 0:1.6.0-7
0:1.6.0-7
libgsf-devel
Red Hat:enterprise_linux:3::as
before 0:1.6.0-7
0:1.6.0-7
libgsf
Red Hat:enterprise_linux:3::desktop
before 0:1.6.0-7
0:1.6.0-7
libgsf-debuginfo
Red Hat:enterprise_linux:3::desktop
before 0:1.6.0-7
0:1.6.0-7
libgsf-devel
Red Hat:enterprise_linux:3::desktop
before 0:1.6.0-7
0:1.6.0-7
Show 18 moreShow less
Affected packages
PackageAffectedFixed
libgsf
Red Hat:enterprise_linux:3::es
before 0:1.6.0-7
0:1.6.0-7
libgsf-debuginfo
Red Hat:enterprise_linux:3::es
before 0:1.6.0-7
0:1.6.0-7
libgsf-devel
Red Hat:enterprise_linux:3::es
before 0:1.6.0-7
0:1.6.0-7
libgsf
Red Hat:enterprise_linux:3::ws
before 0:1.6.0-7
0:1.6.0-7
libgsf-debuginfo
Red Hat:enterprise_linux:3::ws
before 0:1.6.0-7
0:1.6.0-7
libgsf-devel
Red Hat:enterprise_linux:3::ws
before 0:1.6.0-7
0:1.6.0-7
libgsf
Red Hat:enterprise_linux:4::as
before 0:1.10.1-2
0:1.10.1-2
libgsf-debuginfo
Red Hat:enterprise_linux:4::as
before 0:1.10.1-2
0:1.10.1-2
libgsf-devel
Red Hat:enterprise_linux:4::as
before 0:1.10.1-2
0:1.10.1-2
libgsf
Red Hat:enterprise_linux:4::desktop
before 0:1.10.1-2
0:1.10.1-2
libgsf-debuginfo
Red Hat:enterprise_linux:4::desktop
before 0:1.10.1-2
0:1.10.1-2
libgsf-devel
Red Hat:enterprise_linux:4::desktop
before 0:1.10.1-2
0:1.10.1-2
libgsf
Red Hat:enterprise_linux:4::es
before 0:1.10.1-2
0:1.10.1-2
libgsf-debuginfo
Red Hat:enterprise_linux:4::es
before 0:1.10.1-2
0:1.10.1-2
libgsf-devel
Red Hat:enterprise_linux:4::es
before 0:1.10.1-2
0:1.10.1-2
libgsf
Red Hat:enterprise_linux:4::ws
before 0:1.10.1-2
0:1.10.1-2
libgsf-debuginfo
Red Hat:enterprise_linux:4::ws
before 0:1.10.1-2
0:1.10.1-2
libgsf-devel
Red Hat:enterprise_linux:4::ws
before 0:1.10.1-2
0:1.10.1-2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-4514 is a high vulnerability (CVSS 7.5) in Libgsf, published November 30, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.43%, the 91st percentile. Fixed in libgsf 1.14.2-1.

References

Show 27 moreShow less
MoveEnter Open