Every CVE Search/ Get API key

CVE-2006-5815

Stack-based buffer overflow in the sreplace function in ProFTPD 1.3.0 and earlier allows remote...

10.0 HighPublic exploitFix available

Stack-based buffer overflow in the sreplace function in ProFTPD 1.3.0 and earlier allows remote attackers, probably authenticated, to cause a denial of service and execute arbitrary code, as demonstrated by vd_proftpd.pm, a "ProFTPD remote exploit."

Exploit likelihood

75.5%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

Stack-based buffer overflow in the sreplace function in ProFTPD 1.3.0 and earlier allows remote attackers, probably authenticated, to cause a denial of service and execute arbitrary code, as demonstrated by vd_proftpd.pm, a "ProFTPD remote exploit."

Record
CVE-2006-5815
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Stack-based buffer overflow in the sreplace function in ProFTPD 1.3.0 and earlier allows remote attackers, probably authenticated, to cause a denial of service and execute arbitrary code, as demonstrated by vd_proftpd.pm, a "ProFTPD remote exploit."

Record
CVE-2006-5815
Updated
2026-11-02
EUVDEUVD-2006-5799 No score

Stack-based buffer overflow in the sreplace function in ProFTPD 1.3.0 and earlier allows remote attackers, probably authenticated, to cause a denial of service and execute arbitrary code, as demonstrated by vd_proftpd.pm, a "ProFTPD remote exploit."

Record
EUVD-2006-5799
Updated
2026-11-03
GitHub AdvisoriesGHSA-q4h4-p4xh-74q7 No score

Stack-based buffer overflow in the sreplace function in ProFTPD 1.3.0 and earlier allows remote...

Stack-based buffer overflow in the sreplace function in ProFTPD 1.3.0 and earlier allows remote attackers, probably authenticated, to cause a denial of service and execute arbitrary code, as demonstrated by vd_proftpd.pm, a "ProFTPD remote exploit."

Record
GHSA-q4h4-p4xh-74q7
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Stack-based buffer overflow in the sreplace function in ProFTPD 1.3.0 and earlier allows remote attackers, probably authenticated, to cause a denial of service and execute arbitrary code, as demonstrated by vd_proftpd.pm, a "ProFTPD remote exploit."

Record
CVE-2006-5815
Updated
2026-11-02
OSVDEBIAN-CVE-2006-5815 No score

Stack-based buffer overflow in the sreplace function in ProFTPD 1.3.0 and earlier allows remote attackers, probably authenticated, to cause a denial of service and execute arbitrary code, as demonstrated by vd_proftpd.pm, a "ProFTPD remote exploit."

Record
DEBIAN-CVE-2006-5815
Updated
2026-11-02
OSVopenSUSE-SU-2024:11196-1 No score

proftpd-1.3.6e-1.10 on GA media

These are all security issues fixed in the proftpd-1.3.6e-1.10 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11196-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
proftpd-dfsg
Debian:12
before 1.3.0-15
1.3.0-15
proftpd-dfsg
Debian:13
before 1.3.0-15
1.3.0-15
proftpd-dfsg
Debian:14
before 1.3.0-15
1.3.0-15
proftpd
Debian:3.1
From an advisory covering 2 CVEs
before 1.2.10-15sarge3, plus listed versions
1.2.10-151.2.10-15sarge11.2.10-15sarge1.0.11.2.10-15sarge2
1.2.10-15sarge3
proftpd
openSUSE:Tumbleweed
From an advisory covering 7 CVEs
before 1.3.6e-1.10
1.3.6e-1.10

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
affected, exploits, facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-5815 is a high vulnerability (CVSS 10.0) in Proftpd Project Proftpd, published November 8, 2006. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 75.5%, the 99th percentile. Fixed in proftpd-dfsg 1.3.0-15.

References

Show 29 moreShow less
MoveEnter Open